Bug 70926 - Configuration tweaks
Configuration tweaks
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-06 18:57 EDT by Havoc Pennington
Modified: 2007-04-18 12:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 12:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2002-08-06 18:57:32 EDT
This is kdebase 3.0.2-7.2

- Everyone who sees the thing where the panel icons "grow" when you 
mouse over them says that it looks really bad (it's because it doesn't work
quite right - it needs to grow smoothly instead of jumping in one step,
perhaps). In OS X this feature is serving a useful purpose of growing the mouse
target and zooming the icon so you can see what it is, in kicker it just isn't
implemented in a way that adds anything.

Also, it weirdly only happens on some of the icons (not on Mozilla, Evolution
icons).

- Another nice tweak might be to change the default panel size from 46 to 48, so
that the 48x48 icons fully fit on there.

- KOrganizer system tray gadget should not be there, as Evolution is already
there; and the RHN tray icon should appear in this space.

- The panel should not have hide/show arrows by default.

- With this kdebase version I still have the default Qt theme instead of
Wonderland? Is that expected?

- I also still have a Utilities menu merged in? this may be the result of 
an old install.

- The order of icons on the desktop should be inverted, i.e. Home at the top and
Trash on the bottom.
Comment 1 Havoc Pennington 2002-08-06 18:58:49 EDT
Note, I have a system that's partially installed with old code, so some of these
issues may no longer apply.
Comment 2 Ngo Than 2002-08-07 11:56:14 EDT
- have you set Wonderland style before update? i cannot reproduce it here.
  it work for me.

- Please take a look in $HOME/.kde/share/applnk if you still have old desktop  
  files here. What does "cat /etc/kderc"  say ?
  The current KDE packages only merges /var/lib/menu/kde in.

- i will fix another issues "panel icons grow", "panel size from 46 to 48",
  "KOrganizer system tray gadget", "hide/show arrows", "The order of icons" in
  next kdebase-3.0.2-9 or newer

Perhaps we should add konsole/gnome-termimal on panel?

Comment 3 Havoc Pennington 2002-08-07 12:36:46 EDT
- with latest kdebase and qt from dist-8.0-toolchain installed, I logged
  in with a fresh user, clicked "skip wizard" on kpersonalizer, and 
  I don't have the Wonderland Qt theme by default. I do have the wonderland
  KWin theme.

- I do still have a "Utilities" submenu on this fresh user account, 
  containing only one item ("Ami") - maybe you only see this if you install 
  Ami

- For terminal on panel, there was another bug report; my rationale 
  is that if you know how to use a terminal, you will have no trouble 
  adding an icon there, and we are already short of space for the task
  list.
Comment 4 Havoc Pennington 2002-08-07 12:43:23 EDT
OK, if I do a new user and go through all of kpersonalizer then I do get the
right theme. But even plain Qt apps run under GNOME should be getting Wonderland
by default, we need to set that theme as the global default that you always get.

In kpersonalizer, as discussed on bug #59697, even if we keep kpersonalizer for
language selection, the "choose your look and feel" page _must_ come out when
you first log in. If it stayed, the description of the Red Hat option is
somewhat wrong; but it should not stay, it's just really not right to have this
page.

It would be fine to have this page if kpersonalizer did not run on login (if you
had to run it from the menus after logging in).
Comment 5 Ngo Than 2002-08-29 12:46:00 EDT
It's fixed in 3.0.3-8
Comment 6 Jay Turner 2002-09-03 21:13:56 EDT
Fix confirmed with kdebase-3.0.3-10.

Note You need to log in before you can comment on or make changes to this bug.