Bug 709290 - Review Request: perl-LWP-Protocol-http10 - Legacy HTTP/1.0 support for LWP
Summary: Review Request: perl-LWP-Protocol-http10 - Legacy HTTP/1.0 support for LWP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: rt4-dependencies-tracker
TreeView+ depends on / blocked
 
Reported: 2011-05-31 10:01 UTC by Ralf Corsepius
Modified: 2012-01-26 22:56 UTC (History)
3 users (show)

Fixed In Version: perl-LWP-Protocol-http10-6.02-3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-26 22:56:16 UTC
ppisar: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Ralf Corsepius 2011-05-31 10:01:33 UTC
Spec URL: http://corsepiu.fedorapeople.org/packages/perl-LWP-Protocol-http10.spec
SRPM URL: http://corsepiu.fedorapeople.org/packages/perl-LWP-Protocol-http10-6.02-1.fc16.src.rpm 

Description:
The LWP::Protocol::http10 module provide support for using HTTP/1.0
protocol with LWP. To use it you need to call LWP::Protocol::implementor()
to override the standard handler for http URLs.

Notes:
1) This package does not build on Fedora < 16, because Fedora < 16 does not provide sufficiently new modules this package depends upon.
2) This package is an optional dependency of perl-Plack's testsuite.

Comment 1 Petr Pisar 2011-06-09 14:09:17 UTC
Standalone and in-SRPM spec files differ in changelog entry. I will review the standalone one as its time stamp is newer.

Source tar ball is original. Ok.
Summary verified from lib/LWP/Protocol/http10.pm. Ok.
License verified from lib/LWP/Protocol/http10.pm. Ok.
No perl C binding, noarch architecture is Ok.
Description verified from lib/LWP/Protocol/http10.pm. Ok.

TODO: Description contains orthographic mistake: `module _provide_ support'. There should be `provides'.

TODO: No tests are presented, thus the package in question is not executed at build time. You can remove all BuildRequires except perl(ExtUtils::MakeMaker).

TODO: Remove %defattr from %files section as this is implicit already.

$ rpmlint perl-LWP-Protocol-http10.spec ../SRPMS/perl-LWP-Protocol-http10-6.02-1.fc16.src.rpm ../RPMS/noarch/perl-LWP-Protocol-http10-6.02-1.fc16.noarch.rpm 
perl-LWP-Protocol-http10.src: W: spelling-error %description -l en_US implementor -> implement or, implement-or, implementer
perl-LWP-Protocol-http10.src: W: spelling-error %description -l en_US http -> HTTP, HP, HT
perl-LWP-Protocol-http10.noarch: W: spelling-error %description -l en_US implementor -> implement or, implement-or, implementer
perl-LWP-Protocol-http10.noarch: W: spelling-error %description -l en_US http -> HTTP, HP, HT
2 packages and 1 specfiles checked; 0 errors, 4 warnings.
These are literals. Ok.

$ rpm -q -lv -p ../RPMS/noarch/perl-LWP-Protocol-http10-6.02-1.fc16.noarch.rpm 
drwxr-xr-x    2 root    root                        0 Jun  9 15:56 /usr/share/doc/perl-LWP-Protocol-http10-6.02
-rw-r--r--    1 root    root                      470 Apr  9 12:17 /usr/share/doc/perl-LWP-Protocol-http10-6.02/Changes
-rw-r--r--    1 root    root                      866 Apr  9 12:15 /usr/share/doc/perl-LWP-Protocol-http10-6.02/README
-rw-r--r--    1 root    root                     2164 Jun  9 15:56 /usr/share/man/man3/LWP::Protocol::http10.3pm.gz
drwxr-xr-x    2 root    root                        0 Jun  9 15:56 /usr/share/perl5/vendor_perl/LWP
drwxr-xr-x    2 root    root                        0 Jun  9 15:56 /usr/share/perl5/vendor_perl/LWP/Protocol
-rw-r--r--    1 root    root                     8857 Apr  9 12:15 /usr/share/perl5/vendor_perl/LWP/Protocol/http10.pm
File permissions and layout is Ok.

$ rpm -q --requires -p ../RPMS/noarch/perl-LWP-Protocol-http10-6.02-1.fc16.noarch.rpm |sort |uniq -c
      1 perl(HTTP::Response) >= 6
      1 perl(HTTP::Status) >= 6
      1 perl(IO::Select)  
      1 perl(IO::Socket)  
      1 perl(LWP::Protocol) >= 6
      1 perl(:MODULE_COMPAT_5.12.3)  
      1 perl(strict)  
      1 perl(vars)  
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
FIX: Require perl(URI::Escape) (lib/LWP/Protocol/http10.pm:74).

$ rpm -q --provides -p ../RPMS/noarch/perl-LWP-Protocol-http10-6.02-1.fc16.noarch.rpm |sort |uniq -c
      1 perl(LWP::Protocol::http10) = 6.02
      1 perl-LWP-Protocol-http10 = 6.02-1.fc16
Binary provides Ok.

$ ~/bin/resolvedeps rawhide ../RPMS/noarch/perl-LWP-Protocol-http10-6.02-1.fc16.noarch.rpm 
Binary dependencies resolvable. Ok.

Package builds in F16 (http://koji.fedoraproject.org/koji/taskinfo?taskID=3121698). Ok.

Otherwise package is in line with Fedora and perl packaging guidelines.


Please correct all `FIX' prefixed issues, consider fixing `TODO' items, and provide new spec file.

Resolution: Package NOT approved.

Comment 3 Petr Pisar 2012-01-16 12:57:28 UTC
Spec file changes:

--- perl-LWP-Protocol-http10.spec       2011-05-31 11:52:07.000000000 +0200
+++ perl-LWP-Protocol-http10.spec.1     2012-01-16 08:53:32.000000000 +0100
@@ -1,6 +1,6 @@
 Name:           perl-LWP-Protocol-http10
 Version:        6.02
-Release:        1%{?dist}
+Release:        3%{?dist}
 Summary:        Legacy HTTP/1.0 support for LWP
 License:        GPL+ or Artistic
 Group:          Development/Libraries
@@ -11,21 +11,19 @@
 BuildRequires:  perl(HTTP::Response) >= 6
 BuildRequires:  perl(HTTP::Status) >= 6
 BuildRequires:  perl(LWP::Protocol) >= 6
+
 Requires:       perl(HTTP::Response) >= 6
+%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(HTTP::Response\\)
 Requires:       perl(HTTP::Status) >= 6
+%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(HTTP::Status\\)
 Requires:       perl(LWP::Protocol) >= 6
+%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(LWP::Protocol\\)
 Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
-
-%{?filter_setup:
-# Filter unversioned versions of versioned Requires:
-%filter_from_requires /^perl(HTTP::Response)/d
-%filter_from_requires /^perl(HTTP::Status)/d
-%filter_from_requires /^perl(LWP::Protocol)/d
-%?perl_default_filter
-}
+# Make optional dependency mandatory
+Requires:       perl(URI::Escape)
 
 %description
-The LWP::Protocol::http10 module provide support for using HTTP/1.0
+The LWP::Protocol::http10 module provides support for using HTTP/1.0
 protocol with LWP. To use it you need to call LWP::Protocol::implementor()
 to override the standard handler for http URLs.
 
@@ -54,6 +52,11 @@
 %{_mandir}/man3/*
 
 %changelog
-* Tue May 31 2011 Ralf Corsépius <corsepiu@fedoraproject.org> 6.02-1
-- Initial Fedora package.
+* Mon Jan 16 2012 Ralf Corsépius <corsepiu@fedoraproject.org> 6.02-3
+- Rework filters.
+
+* Fri Jun 19 2011 Ralf Corsépius <corsepiu@fedoraproject.org> 6.02-2
+- Reflect feedback from package review.
 
+* Mon Apr 18 2011 Ralf Corsépius <corsepiu@fedoraproject.org> 6.02-1
+- Specfile autogenerated by cpanspec 1.78.


> TODO: Description contains orthographic mistake: `module _provide_ support'.
> There should be `provides'.
 %description
-The LWP::Protocol::http10 module provide support for using HTTP/1.0
+The LWP::Protocol::http10 module provides support for using HTTP/1.0
Ok.

> TODO: No tests are presented, thus the package in question is not executed at
> build time. You can remove all BuildRequires except perl(ExtUtils::MakeMaker).
Not addressed. Ok.

> TODO: Remove %defattr from %files section as this is implicit already.
Not addressed. Ok.

$ rpmlint  perl-LWP-Protocol-http10.spec ../SRPMS/perl-LWP-Protocol-http10-6.02-3.fc17.src.rpm ../RPMS/noarch/perl-LWP-Protocol-http10-6.02-3.fc17.noarch.rpm 
perl-LWP-Protocol-http10.src: W: spelling-error %description -l en_US implementor -> implementer, implement or, implement-or
perl-LWP-Protocol-http10.src: W: spelling-error %description -l en_US http -> HTTP
perl-LWP-Protocol-http10.noarch: W: spelling-error %description -l en_US implementor -> implementer, implement or, implement-or
perl-LWP-Protocol-http10.noarch: W: spelling-error %description -l en_US http -> HTTP
2 packages and 1 specfiles checked; 0 errors, 4 warnings.
rpmlint Ok.

> FIX: Require perl(URI::Escape) (lib/LWP/Protocol/http10.pm:74).
+# Make optional dependency mandatory
+Requires:       perl(URI::Escape)
Ok.

$ rpm -q --requires -p ../RPMS/noarch/perl-LWP-Protocol-http10-6.02-3.fc17.noarch.rpm |sort |uniq -c
      1 perl(HTTP::Response) >= 6
      1 perl(HTTP::Status) >= 6
      1 perl(IO::Select)  
      1 perl(IO::Socket)  
      1 perl(LWP::Protocol) >= 6
      1 perl(:MODULE_COMPAT_5.14.2)  
      1 perl(strict)  
      1 perl(URI::Escape)  
      1 perl(vars)  
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
Binary requires Ok.

$ resolvedeps rawhide ../RPMS/noarch/perl-LWP-Protocol-http10-6.02-3.fc17.noarch.rpm 
Binary dependencies resolvable. Ok.

Package builds in F17 (http://koji.fedoraproject.org/koji/taskinfo?taskID=3705662). Ok.


Resolution: Package APPROVED.

Comment 4 Ralf Corsepius 2012-01-18 07:10:11 UTC
New Package SCM Request
=======================
Package Name: perl-LWP-Protocol-http10
Short Description: Legacy HTTP/1.0 support for LWP
Owners: corsepiu
Branches: f15 f16
InitialCC: perl-sig

Comment 5 Gwyn Ciesla 2012-01-18 13:35:03 UTC
Git done (by process-git-requests).

Comment 6 Fedora Update System 2012-01-18 17:51:14 UTC
perl-LWP-Protocol-http10-6.02-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-LWP-Protocol-http10-6.02-3.fc16

Comment 7 Fedora Update System 2012-01-19 01:32:53 UTC
perl-LWP-Protocol-http10-6.02-3.fc16 has been pushed to the Fedora 16 testing repository.

Comment 8 Fedora Update System 2012-01-26 22:56:16 UTC
perl-LWP-Protocol-http10-6.02-3.fc16 has been pushed to the Fedora 16 stable repository.


Note You need to log in before you can comment on or make changes to this bug.