Bug 70930 - Installer ignores custom monitor frequencies
Installer ignores custom monitor frequencies
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks: 67217 79578
  Show dependency treegraph
 
Reported: 2002-08-06 20:04 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 12:11:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-06 20:04:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
When the installer fails to detect my monitor's frequency settings, and I enter
them myself, and choose my resolution, upon reboot, I find that the installer
has ignored this information, invented its own monitor settings, and chosen
640x480 for me.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a Viewsonic G773 monitor.
2. Install a fresh copy of Limbo #2
3. When the installer fails to autodetect, use "Custom Monitor" and a frequency
of 30-70kHz/50-180Hz
4. Choose a preferred resolution of something higher than 640x480

Actual Results:  X started with a 640x480 resolution.

The XF86Config file ended up having the correct laundry list of resolutions
written to it, but the monitor frequency was something completely off the wall.
I re-wrote it, restarted X, and everything worked fine, so I'm a little
hard-pressed to tell you WHAT it had chosen.  Narrow frequency ranges. I saw the
same behavior in Limbo #1, so I'm betting it's reproducable Always, though in
truth, I can only say it did it twice--once with each Limbo.

Expected Results:  The installer should have respected custom monitor
frequencies, or else not bothered to ask.

Additional info:  I apologise if this is the wrong component.  "installer" isn't
an option for bugzilla entry--although you can search on it, which is curious.
Comment 1 Alexander Larsson 2002-08-07 08:41:43 EDT
The installer is called "anaconda". Reassigning.
Comment 2 Michael Fulbright 2002-08-14 12:57:03 EDT
Was this install done in text or graphical mode?
Comment 3 Need Real Name 2002-08-14 13:13:23 EDT
The install was done in text mode, because it was a hard disk-based
installation, both times.
Comment 4 Michael Fulbright 2002-08-21 18:02:19 EDT
Appears to work now.
Comment 5 Jay Turner 2003-01-23 12:11:12 EST
Fix confirmed with re0122.nightly tree.

Note You need to log in before you can comment on or make changes to this bug.