Bug 709314 - eject command in the guest does not works properly when guest using host cdrom
eject command in the guest does not works properly when guest using host cdrom
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-05-31 07:04 EDT by Mike Cao
Modified: 2011-08-09 05:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 729225 (view as bug list)
Environment:
Last Closed: 2011-08-09 05:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2011-05-31 07:04:48 EDT
Description of problem:


Version-Release number of selected component (if applicable):
# uname -r
2.6.18-264.el5
# rpm -q kvm
kvm-83-235.el5


How reproducible:
100%

Steps to Reproduce:
1.start guest with /dev/sr0
eg:/usr/libexec/qemu-kvm -M rhel5.6.0 -m 2048 -smp 4,sockets=4,cores=1,threads=1 -name RHEL6u1 -uuid 7c9a4b2c-8d58-6771-7748-0ce92bfd83f7 -monitor stdio -no-kvm-pit-reinjection -boot dc -drive file=/dev/stress/rhel6u1,if=virtio,boot=on,format=raw,cache=none -drive file=/dev/sr0,if=ide,format=raw,cache=none,media=cdrom,bus=1,unit=0 -net nic,macaddr=54:52:00:7d:dd:37,vlan=0,model=virtio -net tap,vlan=0,downscript=no -serial pty -parallel none -usb -usbdevice tablet -vnc :2 -k en-us -vga cirrus -balloon none -notify all
2.change ide1-cd0 to make guest detect cd in the host cdrom.
(qemu)change ide1-cd0 /dev/sr0 (this step due to Bug 709304
3.mount /dev/sr0 in the guest .
#mount /dev/sr0 /opt
4,umount /dev/sr0  
#umount /dev/sr0
5.in the guest #eject
  
Actual results:
the tray open then closed immediately so that I could not get the cd out from host cdrom.
During this time ,qemu-kvm process freezed 

Expected results:
the tray keeps open.
qemu-kvm does not freeze

Additional info:
Comment 2 Ronen Hod 2011-08-09 05:21:12 EDT
Since at best it will be fixed upstream in RHEL7, and it is not a high severity bug, closing it for RHEL5 (5.8)

Note You need to log in before you can comment on or make changes to this bug.