Bug 709319 - [regression] 'mount -a' mounts already mounted directories
[regression] 'mount -a' mounts already mounted directories
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
: 711748 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-31 07:29 EDT by Enrico Scholz
Modified: 2011-07-05 06:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: util-linux-2.19.1-1.2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-05 06:03:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2011-05-31 07:29:34 EDT
Description of problem:

having something like

| /dev/vg01/data          /srv/mnt/data           ext4    noatime,acl,user_xattr  1 2
| /srv/mnt/data/X /srv/X  none    bind

in /etc/fstab causes 'mount -a' to mount /srv/X everytime again:

# cat /proc/mounts  | grep /srv/X
# mount -a
# mount -a
# mount -a
# mount -a
# cat /proc/mounts  | grep /srv/X
/dev/mapper/vg01-data /srv/X ext4 rw,seclabel,noatime,barrier=1,data=ordered 0 0
/dev/mapper/vg01-data /srv/X ext4 rw,seclabel,noatime,barrier=1,data=ordered 0 0
/dev/mapper/vg01-data /srv/X ext4 rw,seclabel,noatime,barrier=1,data=ordered 0 0
/dev/mapper/vg01-data /srv/X ext4 rw,seclabel,noatime,barrier=1,data=ordered 0 0


This breaks the filesystem layout when other fs are mounted below /srv/X.

Things worked fine with Fedora 14.


Version-Release number of selected component (if applicable):

util-linux-2.19.1-1.fc15.x86_64
Comment 1 Karel Zak 2011-06-13 02:21:43 EDT
Fixed by upstream commit 0cac8948216a298deaf5fd30837ed9cc80618f80. The Fedora package will be updated ASAP.
Comment 2 Fedora Update System 2011-06-14 05:35:15 EDT
util-linux-2.19.1-1.1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/util-linux-2.19.1-1.1.fc15
Comment 3 Fedora Update System 2011-06-15 14:30:47 EDT
Package util-linux-2.19.1-1.1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing util-linux-2.19.1-1.1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/util-linux-2.19.1-1.1.fc15
then log in and leave karma (feedback).
Comment 4 Michal Schmidt 2011-07-05 06:03:05 EDT
util-linux-2.19.1-1.1.fc15 was obsoleted.
util-linux-2.19.1-1.2.fc15 reached stable updates already.
Comment 5 Michal Schmidt 2011-07-05 06:06:24 EDT
*** Bug 711748 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.