Bug 709370 - enforcing MLS: mcelog AVC appears
Summary: enforcing MLS: mcelog AVC appears
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks: 772956
TreeView+ depends on / blocked
 
Reported: 2011-05-31 14:29 UTC by Milos Malik
Modified: 2012-02-21 05:46 UTC (History)
4 users (show)

Fixed In Version: selinux-policy-2.4.6-326.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:46:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0158 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2012-02-20 14:53:50 UTC

Description Milos Malik 2011-05-31 14:29:46 UTC
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-minimum-2.4.6-306.el5
selinux-policy-targeted-2.4.6-306.el5
selinux-policy-devel-2.4.6-306.el5
selinux-policy-strict-2.4.6-306.el5
selinux-policy-mls-2.4.6-306.el5
selinux-policy-2.4.6-306.el5

How reproducible:
not sure

Actual results:
----
time->Tue May 31 10:01:01 2011
type=SYSCALL msg=audit(1306850461.963:83): arch=c000003e syscall=2 success=no exit=-13 a0=406a67 a1=0 a2=331e953990 a3=63656420494d4420 items=0 ppid=3054 pid=3057 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm="mcelog" exe="/usr/sbin/mcelog" subj=system_u:system_r:system_crond_t:s0-s15:c0.c1023 key=(null)
type=AVC msg=audit(1306850461.963:83): avc:  denied  { read } for  pid=3057 comm="mcelog" name="mcelog" dev=tmpfs ino=3066 scontext=system_u:system_r:system_crond_t:s0-s15:c0.c1023 tcontext=system_u:object_r:printk_device_t:s15:c0.c1023 tclass=chr_file
----

Expected results:
no AVCs

Comment 1 Milos Malik 2011-05-31 14:33:53 UTC
I though 2 same AVCs appeared but this is different from the previous one:
----
time->Tue May 31 10:01:01 2011
type=SYSCALL msg=audit(1306850461.963:82): arch=c000003e syscall=2 success=no exit=-13 a0=408270 a1=0 a2=3 a3=2d items=0 ppid=3054 pid=3057 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm="mcelog" exe="/usr/sbin/mcelog" subj=system_u:system_r:system_crond_t:s0-s15:c0.c1023 key=(null)
type=AVC msg=audit(1306850461.963:82): avc:  denied  { read } for  pid=3057 comm="mcelog" name="mem" dev=tmpfs ino=2011 scontext=system_u:system_r:system_crond_t:s0-s15:c0.c1023 tcontext=system_u:object_r:memory_device_t:s15:c0.c1023 tclass=chr_file
----

Comment 2 Daniel Walsh 2011-05-31 14:58:04 UTC
The problem is we do not have mcelog policy in RHEL5.  Not sure if mcelog is supposed to be run on an MLS box though.

Comment 3 Miroslav Grepl 2011-11-10 13:01:31 UTC
I think I could add it to make this working. We have it also in Fedora/RHEL6

Comment 4 Daniel Walsh 2011-11-10 13:12:58 UTC
ok

Comment 5 Miroslav Grepl 2011-11-29 16:37:29 UTC
Fixed in selinux-policy-2.4.6-320.el5

Comment 9 Miroslav Grepl 2011-12-22 10:32:47 UTC
These are specific for RHEL5 which we need to add.

Comment 10 Miroslav Grepl 2012-01-05 11:38:31 UTC
Fixed in selinux-policy-2.4.6-324.el5

Comment 16 Miroslav Grepl 2012-01-18 11:25:44 UTC
Fixed in selinux-policy-2.4.6-326.el5

Comment 18 errata-xmlrpc 2012-02-21 05:46:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0158.html


Note You need to log in before you can comment on or make changes to this bug.