Bug 709392 - Gtalk & Empathy "Network error" and "No reason specified"
Summary: Gtalk & Empathy "Network error" and "No reason specified"
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: empathy
Version: 15
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-31 15:28 UTC by okaa.pii
Modified: 2012-08-07 19:46 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-08-07 19:46:54 UTC


Attachments (Terms of Use)
empathy log (facebook) (11.51 KB, text/x-log)
2011-07-24 23:06 UTC, MERCIER Jonathan
no flags Details
empathy log (82.73 KB, text/x-log)
2011-07-25 15:04 UTC, Jakub Hrozek
no flags Details
Gabble log (33.19 KB, application/octet-stream)
2011-07-26 09:03 UTC, MERCIER Jonathan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 39542 None None None Never

Description okaa.pii 2011-05-31 15:28:54 UTC
Description of problem:
When I try to login with my google talk account in Empathy, a red panel with a message appears. It's random between: "Network error" or "No reason specified".

Version-Release number of selected component (if applicable):
empathy: 3.0.2-1.fc15
selinux-policy: 3.9.16-24.fc15

How reproducible:
Just add a Gtalk account.

Steps to Reproduce:
1. Open Empathy
2. Add Gtalk account
  
Actual results:
Red panel with an error message.

Expected results:
Access to my Gtalk contacts and talk with them.

Additional info:
It worked yesterday...

Comment 1 MERCIER Jonathan 2011-07-23 23:16:58 UTC
They are this problem from a long time. I would like to know if a fix come soon ?

Comment 2 Brian Pepple 2011-07-23 23:28:03 UTC
Well, there isn't much information available here to diagnosis what's wrong. I have back-ported some FB & Googletalk fixes (dealing with creating accounts) to Empathy that might solve this (obviously you'll need to delete the account & re-add it for the changes to be picked up). It's sitting in Bodhi right now waiting to be pushed to testing, if you want to try it.

Comment 3 Jakub Hrozek 2011-07-24 12:50:19 UTC
The latest update I picked up from Koji didn't help for me.

Is there any way I can provide more information to help with the bug report?

I'm currently running:
empathy-3.0.2-3.fc15.i686
telepathy-gabble-0.12.2-1.fc15.i686

What seems weird to me is that Jabber worked fine and then stopped and it's the case for both GoogleTalk and different Jabber server. Pidgin works fine with the same account data (sans its Gnome 3 integration).

Comment 4 Brian Pepple 2011-07-24 19:52:16 UTC
(In reply to comment #3)
> Is there any way I can provide more information to help with the bug report?

After attempting to log-in with your Jabber/GoogleTalk accounts in Empathy, go to Help->Debug,and save a copy of your mission-control & gabble logs and attach them here. That should give upstream and me a better idea of what's causing your problem. Thanks!

Comment 5 MERCIER Jonathan 2011-07-24 23:06:49 UTC
Created attachment 514938 [details]
empathy log (facebook)

with latest empathy build from koji (x86_64) i have try for xmpp account all fail see attached file (in this example it is facebook account)

Comment 6 Jakub Hrozek 2011-07-25 15:04:57 UTC
Created attachment 515089 [details]
empathy log

(In reply to comment #5)
> Created attachment 514938 [details]
> empathy log (facebook)
> 
> with latest empathy build from koji (x86_64) i have try for xmpp account all
> fail see attached file (in this example it is facebook account)

I'm attaching my log as well. To my uninitiated eye it looks like the same problem as Jonathan is seeing.

Comment 7 MERCIER Jonathan 2011-07-26 08:56:58 UTC
They are another bug to
In debug window if you select gabble dropdown at left, debug message still mission-control

For get gablle log you need take the old way:
$ GABBLE_DEBUG=all WOCKY_DEBUG=all GABBLE_PERSIST=1 /usr/libexec/telepathy-gabble

you can piping to a file for save log

The problem seem to be: gabble is trying to resolve empty strings so fails to connect

i have check server with:
$ host -t SRV _xmpp-client._tcp.jabber.fr
_xmpp-client._tcp.jabber.fr has SRV record 20 0 5222 im.apinc.org.

So it is good, is empathy bug around connection or gnome3 problem

Comment 8 MERCIER Jonathan 2011-07-26 08:59:50 UTC
the problem start here: gabble-DEBUG: connector_error_disconnect (connection.c:1673): connection failed: g-resolver-error-quark (#0): connection failed: Error resolving '': Name or service not known

Comment 9 MERCIER Jonathan 2011-07-26 09:03:31 UTC
Created attachment 515218 [details]
Gabble log

problem start line 271

Comment 10 MERCIER Jonathan 2011-07-28 08:46:46 UTC
@Jakub Hrozek

if you are behind a proxy upstream works for a patch
else open dconf-editor:
-> system
  -> proxy
     -> mode = none

solved for me

Comment 11 Jakub Hrozek 2011-07-29 04:21:59 UTC
Thanks, Jonathan, that did the trick for me. I wonder why the proxy was set in the first place..

Comment 12 MERCIER Jonathan 2011-07-29 21:11:54 UTC
same strange, maybe a old-update i use fedora-15 since alpha was released ...

So it will solve other problem with other gnome application like epiphany, pino ....

Comment 13 Andrew Elwell 2011-08-19 09:11:26 UTC
Have just had this same problem -- for some reason I had (F15, Gnome3) network settings -> proxy set to 'Auto' with the config URL blank. 

Setting back to 'None' and the xmpp sessions restarted OK (MSN wasn't affected by this)

Comment 14 MERCIER Jonathan 2011-11-13 11:38:13 UTC
yes it was the problem i think, i have do same thing works for me

We can close the bug now

Comment 15 Fedora End Of Life 2012-08-07 19:46:56 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.