Bug 709403 - M2Crypto.SSL.SSLError: (104, 'Connection reset by peer') / Red Hat Employee Subscription
M2Crypto.SSL.SSLError: (104, 'Connection reset by peer') / Red Hat Employee S...
Status: CLOSED DUPLICATE of bug 710174
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: 6.2
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-31 12:04 EDT by John Sefler
Modified: 2014-12-23 09:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-13 12:56:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Entitlement Cert from the Red Hat Employee Subscription (202.13 KB, application/octet-stream)
2011-05-31 12:12 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-05-31 12:04:47 EDT
Description of problem:
After registering with qa@redhat.com credentials and subscribing to the Red Hat Employee Subscription in the stage env, yum repolist fails with "M2Crypto.SSL.SSLError: (104, 'Connection reset by peer')"

Version-Release number of selected component (if applicable):
[root@jsefler-rhel57-beta12-i386 ~]# rpm -q subscription-manager python yum m2crypto
subscription-manager-0.95.5.19-1.git.1.8278e3d.el5
python-2.4.3-44.el5
yum-3.2.22-33.el5
m2crypto-0.16-8.el5


How reproducible:


Steps to Reproduce:

[root@jsefler-rhel57-beta12-i386 ~]# grep hostname /etc/rhsm/rhsm.conf
# Server hostname:
hostname = subscription.rhn.stage.redhat.com
proxy_hostname =
[root@jsefler-rhel57-beta12-i386 ~]# subscription-manager register --username=qa@redhat.com
Password: 
12d7a054-cd9c-40c4-bf0f-410ae02029a0 jsefler-rhel57-beta12-i386.usersys.redhat.com
[root@jsefler-rhel57-beta12-i386 ~]# yum repolist
Loaded plugins: product-id, security, subscription-manager
Updating Red Hat repositories.
repolist: 0
[root@jsefler-rhel57-beta12-i386 ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Employee Subscription
ProductId:         	SYS0395                  
PoolId:            	8a99f981301d740601301e8b3540001d
Quantity:          	25                       
Expires:           	10/04/2011               


ProductName:       	Red Hat Employee Subscription
ProductId:         	SYS0395                  
PoolId:            	8a99f981301d740601301e8b35570027
Quantity:          	unlimited                
Expires:           	10/04/2011               


ProductName:       	Red Hat Employee Subscription
ProductId:         	SYS0395                  
PoolId:            	8a99f981301d740601301e8b357d0034
Quantity:          	10000                    
Expires:           	10/07/2011               


ProductName:       	Red Hat Employee Subscription
ProductId:         	SYS0395                  
PoolId:            	8a99f981301d740601301e8b35a8003e
Quantity:          	unlimited                
Expires:           	10/07/2011               


ProductName:       	Red Hat Employee Subscription
ProductId:         	SYS0395                  
PoolId:            	8a99f981301d740601301e8b35e2004b
Quantity:          	2500                     
Expires:           	05/22/2012               


ProductName:       	Red Hat Employee Subscription
ProductId:         	SYS0395                  
PoolId:            	8a99f981301d740601301e8b35fe0055
Quantity:          	unlimited                
Expires:           	05/22/2012               

[root@jsefler-rhel57-beta12-i386 ~]# subscription-manager subscribe --pool=8a99f981301d740601301e8b35fe0055
[root@jsefler-rhel57-beta12-i386 ~]# yum repolist
Loaded plugins: product-id, security, subscription-manager
Updating Red Hat repositories.
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 178, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 349, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 781, in doCommand
    base.repos.populateSack()
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 260, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 168, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 226, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1233, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1406, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1398, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1388, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1372, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1208, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 989, in _getFileRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 826, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 412, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 398, in _mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 936, in urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 854, in _retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 922, in retryfunc
    fo = URLGrabberFileObject(url, filename, opts)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1010, in __init__
    self._do_open()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1093, in _do_open
    fo, hdr = self._make_request(req, opener)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1202, in _make_request
    fo = opener.open(req)
  File "/usr/lib/python2.4/urllib2.py", line 358, in open
    response = self._open(req, data)
  File "/usr/lib/python2.4/urllib2.py", line 376, in _open
    '_open', req)
  File "/usr/lib/python2.4/urllib2.py", line 337, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.4/site-packages/M2Crypto/m2urllib2.py", line 82, in https_open
    h.request(req.get_method(), req.get_selector(), req.data, headers)
  File "/usr/lib/python2.4/httplib.py", line 810, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python2.4/httplib.py", line 833, in _send_request
    self.endheaders()
  File "/usr/lib/python2.4/httplib.py", line 804, in endheaders
    self._send_output()
  File "/usr/lib/python2.4/httplib.py", line 685, in _send_output
    self.send(msg)
  File "/usr/lib/python2.4/httplib.py", line 652, in send
    self.connect()
  File "/usr/lib/python2.4/site-packages/M2Crypto/httpslib.py", line 47, in connect
    self.sock.connect((self.host, self.port))
  File "/usr/lib/python2.4/site-packages/M2Crypto/SSL/Connection.py", line 174, in connect
    ret = self.connect_ssl()
  File "/usr/lib/python2.4/site-packages/M2Crypto/SSL/Connection.py", line 167, in connect_ssl
    return m2.ssl_connect(self.ssl, self._timeout)
M2Crypto.SSL.SSLError: (104, 'Connection reset by peer')
[root@jsefler-rhel57-beta12-i386 ~]# 

  
Actual results:


Expected results:


Additional info:
Comment 1 John Sefler 2011-05-31 12:12:55 EDT
Created attachment 502035 [details]
Entitlement Cert from the Red Hat Employee Subscription

[root@jsefler-rhel57-beta12-i386 entitlement]# ls -lhs 4130092168599250812.pem 
212K -rw-r--r-- 1 root root 203K May 31 11:47 4130092168599250812.pem

Note: this is the biggest entitlement cert I've seen.
Comment 5 Bryan Kearney 2011-07-13 12:56:41 EDT
No updates, just bug triage.

*** This bug has been marked as a duplicate of bug 710174 ***

Note You need to log in before you can comment on or make changes to this bug.