Bug 709454 - Install VMs using ISO on NFS shares fail
Install VMs using ISO on NFS shares fail
Status: CLOSED DUPLICATE of bug 702044
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Laine Stump
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-31 14:21 EDT by Steve Reichard
Modified: 2011-07-12 02:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-02 16:34:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Reichard 2011-05-31 14:21:13 EDT
Description of problem:
We have always kept our our collections of ISO we we install guests on an NFS share.  This was not previously an issue, however on a RHEL 6.1 hosts this will fail and required me to copy the ISO locally.


If the NFS is mount using NFS3 I see this error:
Unable to complete install: 'internal error process exited while connecting to monitor: char device redirected to /dev/pts/6
qemu: could not open disk image /pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso: Permission denied
'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1622, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1193, in start_install
    start_xml, final_xml, is_initial)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1252, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1341, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error process exited while connecting to monitor: char device redirected to /dev/pts/6
qemu: could not open disk image /pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso: Permission denied

To show accessibility - 

[root@cf-vms qemu]# ls -l /pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso 
-rwxrwxrwx. 1 qemu qemu 3520802816 Nov 16  2010 /pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso
[root@cf-vms qemu]# dd if=/pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso of=/dev/null bs=1024
^C417117+0 records in
417116+0 records out
427126784 bytes (427 MB) copied, 3.81563 s, 112 MB/s

[root@cf-vms qemu]# dd if=/pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso of=/dev/null bs=1024k
3357+1 records in
3357+1 records out
3520802816 bytes (3.5 GB) copied, 26.5434 s, 133 MB/s
[root@cf-vms qemu]# 


If it is mounted NFSV4, I see this:

Unable to complete install: 'unable to set user and group to '107:107' on '/net/refarch.cloud.lab.eng.bos.redhat.com/pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso': Invalid argument'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1622, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1193, in start_install
    start_xml, final_xml, is_initial)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1252, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1341, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: unable to set user and group to '107:107' on '/net/refarch.cloud.lab.eng.bos.redhat.com/pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso': Invalid argument

showing accessibility again - 


[root@cf-vms qemu]# ls -l /net/refarch.cloud.lab.eng.bos.redhat.com/pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso 
-rwxrwxrwx. 1 4294967294 4294967294 3520802816 Nov 16  2010 /net/refarch.cloud.lab.eng.bos.redhat.com/pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso
[root@cf-vms qemu]# dd if=/net/refarch.cloud.lab.eng.bos.redhat.com/pub/kits/os/Fedora/14/x86_64/Fedora-14-x86_64-DVD.iso of=/dev/null bs=1024k
3357+1 records in
3357+1 records out
3520802816 bytes (3.5 GB) copied, 31.1087 s, 113 MB/s
[root@cf-vms qemu]# 



Version-Release number of selected component (if applicable):

[root@cf-vms qemu]# uname -a
Linux cf-vms.cloud.lab.eng.bos.redhat.com 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue May 10 15:42:40 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
[root@cf-vms qemu]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.1 (Santiago)
[root@cf-vms qemu]# 
[root@cf-vms qemu]# yum list libvirt virt-manager 
Loaded plugins: product-id, refresh-packagekit, rhnplugin, subscription-manager
Updating Red Hat repositories.
Installed Packages
libvirt.x86_64                                                                 0.8.7-18.el6                                                            @rhel-x86_64-server-6
virt-manager.noarch                                                            0.8.6-4.el6                                                             @rhel-x86_64-server-6
[root@cf-vms qemu]

How reproducible:
 everytime



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Laine Stump 2011-06-02 16:34:25 EDT
This is the same problem as Bug 702044 - chown returns EINVAL for this failure, but we're only ignoring EOPNOTSUPP, EPERM, and EROFS. My guess is that chown previously returned one of these other errors, but has been changed for some reason.

*** This bug has been marked as a duplicate of bug 702044 ***

Note You need to log in before you can comment on or make changes to this bug.