Bug 70952 - files missing from package, e.g. findsmb
files missing from package, e.g. findsmb
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: samba (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-07 04:52 EDT by Michael Schwendt
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 10:43:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-08-07 04:52:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020804

Description of problem:
While Samba's WHATSNEW.txt reads

Changes in 2.2.5

12) Include findsmb perl script as part of the "make install" process

Red Hat's package does not include "findsmb" any longer. No mention of it in the
package changelog as why it was dropped. If it was dropped deliberately, at
least mention that in the package changelog, please.

Short-circuit installation of the compiled sources via spec file gives:

error: Installed (but unpackaged) file(s) found:
   /usr/bin/findsmb
   /usr/bin/tdbbackup
   /usr/share/man/man1/findsmb.1.gz
   /usr/share/man/man1/smbsh.1.gz
   /usr/share/man/man8/pdbedit.8.gz

Version-Release number of selected component (if applicable):
2.2.5-8
Comment 1 Trond Eivind Glomsrxd 2002-08-08 11:59:41 EDT
It was removed because it's trusting host name input too much.
Comment 2 Michael Schwendt 2002-08-08 13:39:24 EDT
Ok, would be nice if you mentioned such changes in the spec file changelog.
Comment 3 Andrew Bartlett 2002-09-01 07:03:06 EDT
Was this pushed back upstream?  I can't remember a report to security@samba.org.
 Please, if you modify samba (particulary for secruity reasons) we want to know
about it - not everybody takes the RedHat distribution...

Andrew Bartlett
Samba Team
Comment 4 gregrwm 2003-06-19 07:55:26 EDT
"trusting host name input too much"?  no comprendo.  i'd like a better clue why
findsmb, which i have found quite useful, has been pulled (while meanwhile i'm
off to seek where i can find a copy for my use anyway).
Comment 5 Michael Schwendt 2003-06-19 08:04:23 EDT
In the src.rpm in the original Samba tarball, it's still included for Mandrake
Linux (it's just a Perl script): samba-2.2.7a/packaging/Mandrake/findsmb

Note You need to log in before you can comment on or make changes to this bug.