Bug 709520 - Add "magic" definition for Canon CR2 RAW format
Summary: Add "magic" definition for Canon CR2 RAW format
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: file
Version: 5
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Kaluža
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-31 21:24 UTC by kevin
Modified: 2011-06-11 04:18 UTC (History)
1 user (show)

Fixed In Version: file-5.04-17.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 709846 (view as bug list)
Environment:
Last Closed: 2011-06-11 04:18:53 UTC


Attachments (Terms of Use)

Description kevin 2011-05-31 21:24:44 UTC
Description of problem: Add entry to the magic file for Canon's RAW image format (*.cr2)

Version-Release number of selected component (if applicable): n/a

How reproducible: n/a

Steps to Reproduce: n/a
  
Actual results:  n/a

Expected results:  n/a

Additional info: See following "diff" report

diff /usr/share/misc/magic magic
8144a8145,8146
> 0     string          II\x2a\x00\x10\x00\x00\x00CR\x02\x00    Canon CR2 RAW image data, little-endian
> !:mime        image/tiff

Comment 1 kevin 2011-05-31 21:26:16 UTC
Should add that http://lclevy.free.fr/cr2/#key_info contains a bit of an explanation of the file format.

Comment 2 Jan Kaluža 2011-06-01 06:35:35 UTC
What version of File package do you use please? This format detection is already supported and works for me.

Comment 3 kevin 2011-06-01 09:23:05 UTC
$ file -v
file-5.04
magic file from /usr/share/misc/magic

$ file -m /usr/share/misc/magic.orig IMG_00092.CR2
IMG_0092.CR2: TIFF image data, little-endian

I've updated the system magic file, hence the "-m". So, with my patch:

$ file IMG_00092.CR2
IMG_0092.CR2: Canon CR2 RAW image data, little-endian

Comment 4 kevin 2011-06-01 21:11:57 UTC
BTW: Because of the similarity of the magic data, the CR2 definition must precede the TIFF definition.

Comment 5 Fedora Update System 2011-06-02 05:25:20 UTC
file-5.04-17.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/file-5.04-17.fc14

Comment 6 Fedora Update System 2011-06-03 05:31:48 UTC
Package file-5.04-17.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing file-5.04-17.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/file-5.04-17.fc14
then log in and leave karma (feedback).

Comment 7 kevin 2011-06-09 03:48:44 UTC
Just installed and "yum update'd" F15 - works like a charm. Thanks to all involved.

Comment 8 Fedora Update System 2011-06-11 04:18:47 UTC
file-5.04-17.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.