Bug 70962 - UTF-8 locale not properly recognized
UTF-8 locale not properly recognized
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: python (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-07 06:43 EDT by Daniel Resare
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 18:42:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Resare 2002-08-07 06:43:29 EDT
Description of Problem:
Since redhat now defaults to UTF-8 locale settings, that implies that
communications through the console should be utf-8 encoded. On the contrary to
this, when i start the python interpreter in an UTF-8 locale data that is input
is treated as if the input was in the iso-8859-1 encoding.

Consider for example the following session:

[noa@ulysses c]$ echo $LANG
sv_SE.UTF-8
[noa@ulysses c]$ python
Python 2.2.1 (#1, Jul 25 2002, 18:55:29) 
[GCC 3.2 20020720 (Red Hat Linux Rawhide 3.2-0.1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> s = u"e"    #this aring is entered with my swedish keyboard
>>> len(s)
2


Version-Release number of selected component (if applicable):
python-2.2.1-14
Comment 1 Trond Eivind Glomsrxd 2002-08-12 18:42:09 EDT
Verified :(
Comment 2 Trond Eivind Glomsrxd 2002-09-03 11:40:03 EDT
Needs fixing upstream... python doesn't have a concept of unicode input atm :(.

Note You need to log in before you can comment on or make changes to this bug.