Bug 709759 - help->Install New Software dialog fails to render available software list
help->Install New Software dialog fails to render available software list
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
14
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-01 11:03 EDT by Russell Davies
Modified: 2012-05-11 16:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 09:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screen shot of Add New Software dialog not rendering the available software list. (55.38 KB, image/png)
2011-06-01 11:03 EDT, Russell Davies
no flags Details

  None (edit)
Description Russell Davies 2011-06-01 11:03:19 EDT
Created attachment 502298 [details]
Screen shot of Add New Software dialog not rendering the available software list.

Description of problem:

The install new software dialog box does not render the available software list. Use of the "select all" button indicates that software is available. 

Version-Release number of selected component (if applicable):
eclipse-platform 3.6.1-6.2.fc14

How reproducible:
Always. 

Steps to Reproduce:
1. Help->Install New Software
2. Select a repository
3. Observer that available software list does not populate
4. Hit the "select all" button.
5. Observer message that "X items selected", where X is some positive integer. 
  
Actual results:
Available software list does not render.  Example screen capture is attached. 

Expected results:
Available software list should render

Additional info:
found the following, which relates to an old bug with similar behaviour: http://www.paulpepper.com/blog/2009/11/eclipse-empty-available-software-list.html

The suggested work-around, of setting the GDK_NATIVE_WINDOWS=1 environment variable prior to launching eclipse from the command line, does NOT work in my case.

I'm setting the severity to high, because not being able to install plugins is a blocker for at least me (and probably others), and I don't know of any work-around.
Comment 1 Andrew Overholt 2011-06-01 11:25:48 EDT
What happens if you resize the dialog or the available software list?

FWIW I haven't seen this behaviour in a very long time.  I'm on x86_64 but I can't see that making much of a difference here.
Comment 2 Russell Davies 2011-06-01 12:29:57 EDT
Resizing doesn't cause the list to render.  So, it's deeper than just forcing a paint event. 

I hadn't seen this problem before today.  The last time I used this dialog to install software was about 2 months ago, and everything worked fine at that time.  

I've just installed eclipse on another machine here - completely fresh install.  The issue does *NOT* exist on that machine.  So, it seems likely that this is specific to the local configuration or installed plugins.  

How do I go about debugging this further?  Does eclipse have a verbose debug mode?
Comment 3 Andrew Overholt 2011-06-01 17:20:44 EDT
One can debug individual plugins but I'm not sure where one would put debugging information. Chris (zx)?
Comment 4 Alexander Kurtakov 2011-06-08 03:11:48 EDT
Setting proper Fedora version.
Comment 5 Wan 2011-06-10 06:21:44 EDT
I had the exact same problem, but on Ubuntu 10.10. I solved it by removing the .metadata from my workspace before starting Eclipse - the .metadata was created by a previous version (Galileo).
Comment 6 Russell Davies 2011-06-10 07:57:05 EDT
In my case, removing .metadata also results in the install software dialog box working as expected. 

However, it also leaves me with a blank workspace.   

Is there a simple way to discover exactly what, under .metadata, is causing the problem, so that it can be fixed without having to recreate the whole workspace?
Comment 7 Alexander Kurtakov 2012-04-30 08:39:13 EDT
Is this reproducible with supported Fedora? F-14 is dead and F-15 will be in a couple of months.
Comment 8 Russell Davies 2012-04-30 09:08:29 EDT
Hello.  I no longer see the reported issue in F16. Thanks.
Comment 9 Alexander Kurtakov 2012-04-30 09:14:16 EDT
As per user report closign as fixed.
Comment 10 Russell Davies 2012-05-11 16:36:52 EDT
Hello,

I spoke too soon.  Exactly the same thing now happening again.   

OS = F16
eclipse version 3.7.1  build-id R3_7_1

Any chance of re-opening for F16?  

Thanks

Note You need to log in before you can comment on or make changes to this bug.