Bug 709791 - Review Suggestions for Tomcat - Apache Servlet/JSP Engine, RI for Servlet 3.0/JSP 2.2 API
Review Suggestions for Tomcat - Apache Servlet/JSP Engine, RI for Servlet 3.0...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tomcat (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ivan Afonichev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-01 12:07 EDT by Ole
Modified: 2011-06-08 07:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-08 07:20:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch with review modifications (1.22 KB, patch)
2011-06-01 12:08 EDT, Ole
no flags Details | Diff

  None (edit)
Description Ole 2011-06-01 12:07:13 EDT
The bindir definition can be shortened by replacing 
%{_datadir}/%{name}
with 
%{homedir}

Might want to replace "tomcat" with %{name} in the add user and group block:

# add the tomcat user and group
%{_sbindir}/groupadd -g %{tcuid} -r tomcat 2>/dev/null || :
%{_sbindir}/useradd -c "Apache Tomcat" -u %{tcuid} -g tomcat \
    -s /bin/nologin -r -d %{homedir} tomcat 2>/dev/null || :

In the line:
%{_javadir}/%{name}/%{name}-el-%{elspec}-api.jar


%{_javadir}/%{name} can be replaced with:
%{libdir}?
Comment 1 Ole 2011-06-01 12:08:12 EDT
Created attachment 502313 [details]
Patch with review modifications
Comment 2 Ole 2011-06-01 12:15:33 EDT
The original spec defined in:
https://bugzilla.redhat.com/show_bug.cgi?id=700199
Comment 3 Alexander Kurtakov 2011-06-01 13:35:40 EDT
Wrong component - this should have been filed against tomcat itself.
Also providing a git formatted patch that the maintainer can just git am your_patch would be helpful.
Comment 4 Alexander Kurtakov 2011-06-08 07:20:50 EDT
Looks like Ivan applied it in http://pkgs.fedoraproject.org/gitweb/?p=tomcat.git;a=commitdiff;h=ca271e5d851bea547f2020de374e685531303f18
Closing.
Comment 5 Ivan Afonichev 2011-06-08 07:29:54 EDT
I'm not sure that setting username to variable is a good idea
tomcat6 and tomcat5 are using tomcat username
httpd is using apache username...

Note You need to log in before you can comment on or make changes to this bug.