Bug 70981 - Invalid partition table problems in RH7.2/7.3 installation
Invalid partition table problems in RH7.2/7.3 installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-07 12:05 EDT by Elizabeth Cherry
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error from anaconda (31.02 KB, text/plain)
2002-08-07 12:06 EDT, Elizabeth Cherry
no flags Details

  None (edit)
Description Elizabeth Cherry 2002-08-07 12:05:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Trying to install RH on a new laptop, HP Pavilion ZE 5000 series. 
First tried RH7.3 and consistently got errors related to the 
partition table, such as invalid partition table, wrong signature. Initially we 
were trying to set up partitions in Windows XP using Partition Magic but we got 
the same problems when we tried to let linux set up partitions automatically, 
and even when we allowed it to overwrite XP. For kicks we tried to install an 
old version 7.0 lying around and it installed with no problems. From there we 
tried to upgrade to 7.3 and RH says there is no linux to upgrade!! Now we are 
working with 7.2 and have found the exact same problems with the partition 
table whether we install over RH7.0 or try to upgrade. We are attaching a 
representative error file. We obtained this bug by trying to install, have the 
installer automatically partition, and remove all partitions on the system. 
Initially we get an invalid partition table error, wrong signature f82, which 
if ignored gives messages that the partition table is inconsistent, and finally 
the installation crashes with the output attached.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install as described above, allowing the installer to automatically 
partition and remove all partitions on the system.
2.
3.
	

Actual Results:  Installer crashed and gave error attached below.

Expected Results:  Successful install.

Additional info:

There seem to be a few similar errors in the database but we are not sure they 
are the same. We are not sure we have a 3ware device but tried making an update 
from RHBA-2001:131 since the problem seemed similar. However, when we tried to 
boot using linux updates, the installer started running but when it asked for 
the diskette with the .img file, the window froze and we could not do anything 
else.
Comment 1 Elizabeth Cherry 2002-08-07 12:06:15 EDT
Created attachment 69304 [details]
error from anaconda
Comment 2 Jeremy Katz 2002-08-13 00:26:01 EDT
These messages:
<4>hda: status error: status=0x58 { DriveReady SeekComplete DataRequest }
<4>hda: drive not ready for command
<4>hda: status error: status=0x58 { DriveReady SeekComplete DataRequest }

indicate problems with the hard drive.  Do you have more luck if you boot with
'linux ide=nodma'?
Comment 3 Elizabeth Cherry 2002-08-13 10:00:39 EDT
We have tried that before and it did not work.
We also tried nousb, apm=off, and combinations.
Please let us know if you need any more information to come up 
with a fix. We are stumped, especially since RH7.0 has no problem 
with the drive or partition table and installs just fine.
Thanks.
Comment 4 Jeremy Katz 2002-08-13 11:43:54 EDT
Sounds like something in the 2.4 kernel not liking your hardware
Comment 5 Elizabeth Cherry 2002-08-13 14:01:22 EDT
OK, but what do we do now? We have spent several weeks already working 
with RH support and the bugzilla system, but we don't have an answer 
yet. Should we anticipate a bug fix, or should we give up with RH and try 
another linux distribution?

Thanks for your help.
Comment 6 Bugzilla owner 2004-09-30 11:39:49 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.