Bug 709902 - [abrt] icedax-1.1.11-2.fc14: exit_wrapper: Process /usr/bin/icedax was killed by signal 11 (SIGSEGV)
Summary: [abrt] icedax-1.1.11-2.fc14: exit_wrapper: Process /usr/bin/icedax was killed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrkit
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0005b95ed00c0818a3563f84a55...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-01 22:24 UTC by Lars Schotte
Modified: 2011-06-15 11:27 UTC (History)
2 users (show)

Fixed In Version: cdrkit-1.1.11-8.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-15 05:42:21 UTC


Attachments (Terms of Use)
File: backtrace (6.48 KB, text/plain)
2011-06-01 22:24 UTC, Lars Schotte
no flags Details

Description Lars Schotte 2011-06-01 22:24:11 UTC
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 6640 bytes
cmdline: cdda2wav -B -Owav dev=/dev/sr0
component: cdrkit
Attached file: coredump, 1331200 bytes
crash_function: exit_wrapper
executable: /usr/bin/icedax
kernel: 2.6.35.13-91.fc14.i686
package: icedax-1.1.11-2.fc14
rating: 4
reason: Process /usr/bin/icedax was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1306175000
uid: 500

How to reproduce
-----
1. i dont know any more
2.
3.

Comment 1 Lars Schotte 2011-06-01 22:24:14 UTC
Created attachment 502392 [details]
File: backtrace

Comment 2 Honza Horak 2011-06-02 14:50:13 UTC
How to reproduce
-----
1. run icedax -D /dev/cdrom in terminal 1
2. run icedax -D /dev/cdrom in terminal 2, it will wait to terminal 1 is ready
3. press ctrl-c in terminal 1

Comment 3 Fedora Update System 2011-06-03 06:25:54 UTC
cdrkit-1.1.11-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/cdrkit-1.1.11-8.fc15

Comment 4 Fedora Update System 2011-06-03 06:27:01 UTC
cdrkit-1.1.11-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/cdrkit-1.1.11-3.fc14

Comment 5 Fedora Update System 2011-06-04 03:00:04 UTC
Package cdrkit-1.1.11-3.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cdrkit-1.1.11-3.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/cdrkit-1.1.11-3.fc14
then log in and leave karma (feedback).

Comment 6 Jörg Schilling 2011-06-08 12:48:36 UTC
The problems you see here are from the fact that you are using an
unmaintained piece of sofware that is 6 years behind the current
software. The bug-fix you copied from the original software has been
introduced in the original software 2 years ago already....


Another important problem with cdrkit is it's dubious legality.

The original code however is doubtlessly legal and actively maintained. 

I still don't understand why RedHat prefers to distribute code with stil more than 100 well documented bugs and that only offers 50% of the features of the original software.

Why does RedHat spend time to support anti-OSS activities from Debian?

Comment 7 Fedora Update System 2011-06-15 05:42:07 UTC
cdrkit-1.1.11-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-06-15 05:44:11 UTC
cdrkit-1.1.11-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Jörg Schilling 2011-06-15 09:09:44 UTC
Is there any reason why RedHat advertizes unmaintained software of
questionable legality that only exists because of an attack against
the legal and well maintained original software?

Comment 10 Honza Horak 2011-06-15 10:39:14 UTC
Jörg, I don't think it is necessary to begin the same conversation (or monologue?) in every cdrkit bug. Many similar ideas were already said in bug #507108.

Comment 11 Jörg Schilling 2011-06-15 11:27:41 UTC
As long as RedHat distributes the illegal cdrkit instead of the legal
original software and as long as RedHat legal denies even to talk about
this problem, what other opportunity do I have to enclourage you to
start a discussion that ends in RedHat becomming legal again?


Note You need to log in before you can comment on or make changes to this bug.