Bug 709950 - Blank screen
Blank screen
Status: CLOSED DUPLICATE of bug 705609
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
15
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-02 00:46 EDT by Richard Burton
Modified: 2015-01-14 18:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-30 01:04:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Burton 2011-06-02 00:46:44 EDT
Description of problem:
Screen set to dim to save power and 30 minute timeout. Screen is black when I return home from work and only the time and Name with lock symbol are visible in white. Upon typing or pressing keys cntl-alt-del, etc. nothing happens. Pressing Power button logs me out and returns to a normal login screen.

This is the 2nd day this has occurred. Before yesterday this did not occur in F15.

Version-Release number of selected component (if applicable):


How reproducible:
2 days in a row. Did not occur this morning, but did occur this evening.

Steps to Reproduce:
1. Leave F15 running all day long
2. Return from work and try to login.
3.
  
Actual results:
Press any key and black screen with time at the top are the only things visible.

Expected results:
Press any key and login screen is displayed

Additional info: Started occurring 5-31-2011. Occurred twice.
Comment 1 Christian Krause 2011-06-18 15:23:31 EDT
I see this problem as well. I've search for similar bug reports and this one seems to be similar / a duplicate of #705609 .
Comment 2 Richard Burton 2011-06-19 15:13:44 EDT
Fixed since last update!
Comment 3 Christian Krause 2011-06-20 19:21:22 EDT
Richard,

I still see the problem (fully updated F15, 2011-06-20). It seems to be better (most times the password dialog appears immediately), but sometimes it still takes 30-40s until the dialog appears (idle system). It looks like that the time increases with the time of the activated screensaver.

Please can you check, whether you can still reproduce this if you leave your PC a couple of hours in screensaver-mode?
Comment 4 Richard Burton 2011-06-22 00:12:05 EDT
Yes, not fixed. Just it was a good day for this bug.

Very irreproducible. It just happened to me as you describe Christian. I used cntl-r and this got it out of the screen lock. I've actually had one time where I had to power down  and reboot to get back.

It happens as you say when screensaver mode is several hours. Is there a 16 bit counter which wraps?
Comment 5 Christian Krause 2011-08-28 15:24:44 EDT
I have added a reference to the upstream bug report:
https://bugzilla.gnome.org/show_bug.cgi?id=651378

Additionally I'm quite convinced that this bug report and https://bugzilla.redhat.com/show_bug.cgi?id=705609 describe the same issue.

@gnome-shell developers/packagers
Please can you double-check and set one of the bug reports as duplicate of the other?

Is there anything I can do to help to solve the problem? The issue is quite annoying since sometimes it takes up to a minute until you get the login dialog to get out of the screen lock...

As described in the upstream bug report, I can confirm that:
- there are tons of error messages in ~/.xsession-errors:

Window manager warning: Log level 16: _nm_object_get_property: Error getting 'Ssid' for /org/freedesktop/NetworkManager/AccessPoint/281: (19) Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

- in the list of wireless networks there are lots of "<unknown>" entries
Comment 6 Richard Burton 2011-08-30 01:04:18 EDT
You are correct. This bug report is duplicate. Yes very irritating. My only major complaint about F15. Hopefully they find a solution to the various issues identified. <unknown> wireless networks and contingency of gui on this.

*** This bug has been marked as a duplicate of bug 705609 ***
Comment 7 Richard Burton 2011-08-30 01:06:36 EDT
You are correct. This bug report is duplicate. Yes very irritating. My only major complaint about F15. Hopefully they find a solution to the various issues identified. <unknown> wireless networks and contingency of gui on this.

Note You need to log in before you can comment on or make changes to this bug.