This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 709962 - Please change the Chinese font in boot.iso from cjkuni-uming-fonts to wqy-microhei-fonts
Please change the Chinese font in boot.iso from cjkuni-uming-fonts to wqy-mic...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-02 01:52 EDT by Peng Wu
Modified: 2013-07-04 08:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: lorax-16.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 06:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peng Wu 2011-06-02 01:52:56 EDT
Currently when installing Fedora, anaconda uses cjkuni-uming-fonts for Chinese characters.
cjkuni-uming-fonts is from Traditional Chinese community, it missed some bitmap glyphs for Simplified Chinese characters.

The problem is that when anaconda displays characters for Simplified Chinese(chosen from the language screen), the characters of Simplified Chinese will show up with mixed bitmap glyphs and anti-aliased glyphs.

See: 
http://pwu.fedorapeople.org/anaconda/Fedora%2014%20with%20cjkuni-uming-fonts%20Simplified%20Chinese.png

I manually replaced cjkuni-uming-fonts with wqy-microhei-fonts in netinst.iso, and took a screenshot:
http://pwu.fedorapeople.org/anaconda/Fedora%2014%20with%20wqy-microhei-fonts%20Simplified%20Chinese.png

Also I compared the result of Traditional Chinese after switched to wqy-microhei-fonts, this change doesn't affect Traditional Chinese characters rendering.
See:
http://pwu.fedorapeople.org/anaconda/

Please replace the cjkuni-uming-fonts with wqy-microhei-fonts in boot.iso.
Comment 1 Martin Gracik 2011-07-19 06:50:14 EDT
lorax-0.8-1
Comment 2 Martin Gracik 2011-07-19 06:50:50 EDT
(In reply to comment #1)
> lorax-0.8-1

fixed in...

Note You need to log in before you can comment on or make changes to this bug.