Bug 70999 - Install of Redhat 7.2 Laptop with PCMCIA NIC locks up keyboard and PSAUX mouse in X session.
Install of Redhat 7.2 Laptop with PCMCIA NIC locks up keyboard and PSAUX mous...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-07 14:13 EDT by michael a. worden
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 16:49:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michael a. worden 2002-08-07 14:13:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en]C-CCK-MCD DOJ3jx7bf  (WinNT; U)

Description of problem:
The PSAUX mouse and keyboard functions lock up in X session after installing Redhat 7.2 and 7.3 (or 6.2 with the new PCMCIA module) on my 
Winbook XL laptop with Xircom 10/100 XE2000 PCMCIA card (complete specifications are provided below).  All 7.2 and 7.3 installs are in text mode 
because the mouse is not detected.  Redhat 6.2 successfully installs in gui mode and, with updates to the drivers, correctly configures the network 
card without creating any X session problems.  Loading the PCMCIA module from Redhat 6.2 update again locks up the mouse.

Version-Release number of selected component (if applicable): 7.2 and 7.3


How reproducible:
Always

Steps to Reproduce:
1.Install Redhat 7.2 or 7.3
2.Select Text install after mouse probe fails
3.Default GNOME or Laptop Install
4.Grub selected but not automatic X session
5. Unexceptional completion of Install and Reboot
6. xf86config
7. startx
8. gui loads GNOME
	

Actual Results:  GNOME loads and looks beautiful but PSAUX Mouse and keyboad lock up.  The PSAUX Mouse at IRQ 12 is displaced by the  the 
PCMCIA controller (i82365).

Expected Results:  I should have been able to use a GNOME X session using PSAUX mouse and keyboard.  

Additional info:

I was able to diagnose this problem using another distro, Peanut Linux. Peanut has the same problem as 7.2 and 7.3, however, Peanut disables 
PCMCIA services until after the install.  With Peanut, the install runs fine and the X session is fine.  When I edited the /etc/rc.d/rc.S to allow detection 
of the PCMCIA, the nic is configured and can be pinged. Unfortunately, after PCMCIA starts, the graphical interface will load and lock up (both the 
keyboard and mouse). I am pretty sure that the PCMCIA controller (i82365) knocks the mouse out of its IRQ 12 (the Xircom nic steals the Floppy IRQ 
as well). 

****************************************************
Cat /proc/interrupts from Peanut Linux

BEFORE
CPU0 
0: 683318 XT-PIC timer
1: 5263 XT-PIC keyboard
2: 0 XT-PIC cascade
6: 49 XT-PIC floppy
8: 1 XT-PIC rtc
11: 0 XT-PIC usb-uhci
12: 11802 XT-PIC PS/2 Mouse
14: 15199 XT-PIC ide0
NMI: 0 
LOC: 0 
ERR: 0

AFTER
CPU0 
0: 23202 XT-PIC timer
1: 313 XT-PIC keyboard
2: 0 XT-PIC cascade
3: 4 XT-PIC xirc2ps_cs
8: 1 XT-PIC rtc
11: 0 XT-PIC usb-uhci
12: 4 XT-PIC i82365
14: 13045 XT-PIC ide0
NMI: 0 
LOC: 0 
ERR: 0
*************************************************

I just successfully dual booted this winbook xl laptop with RedHat 6.2 using the default installation. All my efforts failed, including purchased 
installation support personnel from Redhat. Enabling the nic on newer distros causes the psmcia controller to grab IRQ 12, causing the mouse 
and keyboard to lock up in any X session (it also knocked out the floppy).This seems to only apply to laptops that use psaux. This appears to be a 
known problem with newer installations.  Regardless, this laptop is running correctly under Redhat 6.2 with its psaux mouse configured as a ps-2 
generic with the three mouse button emulation. The RedHat 6.2 fails to detect the PCMCIA NIC until after the drivers are updated.  After that, it 
correctly configured the Xircom PCMCIA nic. I only had to use netconfig to supply the IP addresses and the default installation did the rest. 

Here is the correct configuration of the IRQ's under Redhat 6.2. 

# cat /proc/interrupts
CPU0
0: 185024 XT-PIC timer
1: 2265 XT-PIC keyboard
2: 0 XT-PIC cascade
3: 865 XT-PIC xirc2ps_cs
6: 23 XT-PIC floppy
8: 1 XT-PIC rtc
12: 15469 XT-PIC PS/2 Mouse
13: 1 XT-PIC fpu
14: 186451 XT-PIC ide0
15: 4 XT-PIC i82365
NMI: 0
**************************************************************************************************************

SYSTEM SPECIFICATIONS: WinBook XL Laptop

PCMICIA CARD: Xircom 10/100 XE2000
PROCESSOR: Intel Pentium w/MMX 266
MEMORY: 128MB, EDO 60ns, 144-pin SODIMMs 
CACHE: Synchronous, pipeline burst, 256k 
MECHANICAL LAYOUT, Device Bays: "Three spindle" design, CD-ROM, FDD and HDD are
simultaneously available 
CORE LOGIC
Chip Set: Intel Mobile Triton II, 430TX 
Display Chipset: Chips & Technologies 65554 
Memory Type: EDO 
Memory Size: 2 MB 
Bus: PCI 
Maximum Color Depth/Resolution-
External Monitor: 16.7 Million colors/800x600, LCD, 13.1" TFT, Resolution: 800x600 r 1024x768, Depth:
64k 
HARD DRIVE: 20 GB Western Digital (replacement)
CD-ROM: Toshiba
Floppy Drive: 3.5" 1.44 MB- built-in 
MODEM
Type: WinModem / Internal 
Speed: 56600 
Model: LT WinModem 
Supported Standards: v.32 bis, v.32, v.34, v.90 
SOUND
Chip Set: Yamaha YMF715 
Compatibility: SoundBlaster Pro, MS Sound System 
Speakers: 2 Stereo, above keyboard 
Microphone: Mono, in palmrest 
I/O
Chip Set: National Semiconductor NS87338 
PORTS
Parallel: 1 25-pin D-sub connector, Bi-directional, EPP or ECP 
Serial: 1 9-pin D-sub connector, 16550 UART 
USB: 2 Universal Serial Bus Ports
PS/2: 1 mini-DIN 6-pin, keyboard or mouse 
PCMCIA
Chip Set: TI PCI 1131 
Slots: 2 Type II or 1 Type III 
CardBus: Both sockets 
ZoomVideo: Lower socket only 
Keyboard
# Keys: 84 
Windows 95 Keys: Yes 
Power Management
APM: 1.2 
Modes: Normal, standby and suspend 
Suspend to RAM?: Yes 
Suspend to Disk?: Yes 
Pointing Device: 2-button Touchpad
Comment 1 Michael A. Worden 2002-09-14 08:22:54 EDT
i have a bug report on this on the kernel-pcmcia-cs but it really may be the
installation software (anaconda) that is the problem. my only successful install
with both mousepad and PCMCIA NIC functionality on this box was redhat 6.2. 

by upgrading to 7.3 from 6.2, i was able to keep the keyboard and mousepad
function fine but the pcmcia module could not be loaded by 7.3. because the
mousepad stayed working during the upgrade, i'm beginning to think that its not
the kernel module but the installation software anaconda. it seems like the
latest anaconda is in such a hurry to get the NIC up and running to faciliate a
network install that it just runs over the mouse IRQ in the process. in the
meantime, back to redhat 6.2
Comment 2 Brent Fox 2004-04-16 16:49:32 EDT
Closing due to old age.  I'm guessing that it never got looked at
because the component was changed from anaconda to kernel-pcmcia-cs
but the package owner was not changed as well.

Please open a new bug if you are seeing similar behavior with Fedora
Core 1.

Note You need to log in before you can comment on or make changes to this bug.