Bug 710004 - [abrt] SwFEShell::IsAlignPossible killed by signal 11 (SIGSEGV)
[abrt] SwFEShell::IsAlignPossible killed by signal 11 (SIGSEGV)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:5fe58b8a1f9fd89994a1db5c167...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-02 04:48 EDT by Hedayat Vatankhah
Modified: 2011-06-15 01:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: libreoffice-3.3.2.2-10.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-15 01:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: maps (80.76 KB, text/plain)
2011-06-02 04:48 EDT, Hedayat Vatankhah
no flags Details
File: dsos (21.23 KB, text/plain)
2011-06-02 04:48 EDT, Hedayat Vatankhah
no flags Details
File: backtrace (43.91 KB, text/plain)
2011-06-02 04:48 EDT, Hedayat Vatankhah
no flags Details

  None (edit)
Description Hedayat Vatankhah 2011-06-02 04:48:09 EDT
abrt version: 2.0.1
architecture:   x86_64
cmdline:        /usr/lib64/libreoffice/program/swriter.bin -writer file:///home/hedayat/%D9%85%DB%8C%D8%B2%E2%80%8C%DA%A9%D8%A7%D8%B1/RoboCup/RoboCup2011/rules/rc2010rules.odt
comment:        Grouped two rectangles and tried to undo the changes -> crash!
component:      libreoffice
crash_function: GetRegisteredIn
executable:     /usr/lib64/libreoffice/program/swriter.bin
kernel:         2.6.38.6-27.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        libreoffice-writer-3.3.2.2-7.fc15
rating:         4
reason:         Process /usr/lib64/libreoffice/program/swriter.bin was killed by signal 11 (SIGSEGV)
time:           Thu Jun  2 12:13:56 2011
uid:            500
username:       hedayat

backtrace:      Text file, 44966 bytes
dsos:           Text file, 21737 bytes
maps:           Text file, 82698 bytes

environ:
:ORBIT_SOCKETDIR=/tmp/orbit-hedayat
:XDG_SESSION_ID=1
:HOSTNAME=localhost.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=8193
:GPG_AGENT_INFO=/tmp/keyring-MWIMeA/gpg:0:1
:TERM=dumb
:SHELL=/bin/zsh
:DESKTOP_STARTUP_ID=nautilus-7964-localhost.localdomain-libreoffice-1_TIME5260655
:XDG_SESSION_COOKIE=291cf1038d675f9fb37b221e0000000e-1306993936.588003-258596164
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-MWIMeA
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=hedayat
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64
:SSH_AUTH_SOCK=/tmp/keyring-MWIMeA/ssh
:USERNAME=hedayat
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1304,unix/unix:/tmp/.ICE-unix/1304
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:DESKTOP_SESSION=gnome
:PATH=/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/home/hedayat/bin:/usr/local/sbin:/usr/sbin:/sbin
:MAIL=/var/spool/mail/hedayat
:QT_IM_MODULE=xim
:PWD=/home/hedayat
:XMODIFIERS=@im=none
:LANG=en_US.utf8
:GNOME_KEYRING_PID=1296
:KDE_IS_PRELINKED=1
:GDM_LANG=en_US.utf8
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=1
:HOME=/home/hedayat
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=hedayat
:CVS_RSH=ssh
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Vsn6BHP1ot,guid=95631f01e74ff45d40ddfb8600000041
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0.0
:XDG_RUNTIME_DIR=/run/user/hedayat
:GTK_IM_MODULE=gtk-im-context-simple
:G_BROKEN_FILENAMES=1
:XAUTHORITY=/var/run/gdm/auth-for-hedayat-dJAk7T/database
:_=/usr/lib64/libreoffice/program/swriter.bin

event_log:
:2011-06-02-12:17:57> Analyzing crash data
:2011-06-02-12:18:08  Analyzing crash data
:2011-06-02-12:18:20  Analyzing crash data
:2011-06-02-12:18:31  Analyzing crash data
:2011-06-02-12:18:42  Analyzing crash data
:2011-06-02-12:18:53  Analyzing crash data
:2011-06-02-12:19:04  Analyzing crash data
:2011-06-02-12:19:15  Analyzing crash data
:2011-06-02-12:19:26  Analyzing crash data
:2011-06-02-12:19:38  Analyzing crash data
:2011-06-02-12:19:49  Analyzing crash data
:2011-06-02-12:20:00  Analyzing crash data
:2011-06-02-12:20:11  Analyzing crash data
:2011-06-02-12:20:22  Analyzing crash data
:2011-06-02-12:20:33  Analyzing crash data
:2011-06-02-12:20:44  Analyzing crash data
:2011-06-02-12:20:55  Initializing virtual root
:2011-06-02-12:21:06  Initializing virtual root
:2011-06-02-12:21:18  Initializing virtual root
:2011-06-02-12:21:29  Initializing virtual root
:2011-06-02-12:21:40  Initializing virtual root
:2011-06-02-12:21:51  Initializing virtual root
:2011-06-02-12:22:02  Initializing virtual root
:2011-06-02-12:22:13  Initializing virtual root
:2011-06-02-12:22:24  Initializing virtual root
:2011-06-02-12:22:35  Initializing virtual root
:2011-06-02-12:22:46  Initializing virtual root
:2011-06-02-12:22:57  Initializing virtual root
:2011-06-02-12:23:08  Initializing virtual root
:2011-06-02-12:23:19  Initializing virtual root
:2011-06-02-12:23:30  Initializing virtual root
:2011-06-02-12:23:41  Initializing virtual root
:2011-06-02-12:23:52  Initializing virtual root
:2011-06-02-12:24:03  Initializing virtual root
:2011-06-02-12:24:14  Initializing virtual root
:2011-06-02-12:24:25  Initializing virtual root
:2011-06-02-12:24:36  Initializing virtual root
:2011-06-02-12:24:47  Initializing virtual root
:2011-06-02-12:24:58  Initializing virtual root
:2011-06-02-12:25:09  Initializing virtual root
:2011-06-02-12:25:20  Initializing virtual root
:2011-06-02-12:25:31  Initializing virtual root
:2011-06-02-12:25:42  Initializing virtual root
:2011-06-02-12:25:53  Initializing virtual root
:2011-06-02-12:26:04  Initializing virtual root
:2011-06-02-12:26:15  Initializing virtual root
:2011-06-02-12:26:26  Initializing virtual root
:2011-06-02-12:26:37  Initializing virtual root
:2011-06-02-12:26:48  Initializing virtual root
:2011-06-02-12:26:59  Initializing virtual root
:2011-06-02-12:27:10  Initializing virtual root
:2011-06-02-12:27:21  Initializing virtual root
:2011-06-02-12:27:32  Initializing virtual root
:2011-06-02-12:27:43  Initializing virtual root
:2011-06-02-12:27:54  Initializing virtual root
:2011-06-02-12:28:05  Initializing virtual root
:2011-06-02-12:28:16  Initializing virtual root
:2011-06-02-12:28:27  Initializing virtual root
:2011-06-02-12:28:38  Initializing virtual root
:2011-06-02-12:28:50  Initializing virtual root
:2011-06-02-12:29:01  Initializing virtual root
:2011-06-02-12:29:12  Initializing virtual root
:2011-06-02-12:29:23  Initializing virtual root
:2011-06-02-12:29:34  Initializing virtual root
:2011-06-02-12:29:45  Initializing virtual root
:2011-06-02-12:29:56  Initializing virtual root
:2011-06-02-12:30:07  Initializing virtual root
:2011-06-02-12:30:18  Initializing virtual root
:2011-06-02-12:30:29  Initializing virtual root
:2011-06-02-12:30:39  Initializing virtual root
:2011-06-02-12:30:50  Initializing virtual root
:2011-06-02-12:31:01  Initializing virtual root
:2011-06-02-12:31:12  Initializing virtual root
:2011-06-02-12:31:23  Initializing virtual root
:2011-06-02-12:31:34  Initializing virtual root
:2011-06-02-12:31:45  Initializing virtual root
:2011-06-02-12:31:56  Initializing virtual root
:2011-06-02-12:32:07  Initializing virtual root
:2011-06-02-12:32:18  Initializing virtual root
:2011-06-02-12:32:29  Initializing virtual root
:2011-06-02-12:32:40  Initializing virtual root
:2011-06-02-12:32:51  Initializing virtual root
:2011-06-02-12:33:02  Initializing virtual root
:2011-06-02-12:33:13  Initializing virtual root
:2011-06-02-12:33:24  Initializing virtual root
:2011-06-02-12:33:35  Initializing virtual root
:2011-06-02-12:33:46  Initializing virtual root
:2011-06-02-12:33:57  Initializing virtual root
:2011-06-02-12:34:08  Initializing virtual root
:2011-06-02-12:34:19  Initializing virtual root
:2011-06-02-12:34:30  Initializing virtual root
:2011-06-02-12:34:41  Initializing virtual root
:2011-06-02-12:34:52  Initializing virtual root
:2011-06-02-12:35:03  Initializing virtual root
:2011-06-02-12:35:14  Initializing virtual root
:2011-06-02-12:35:25  Initializing virtual root
:2011-06-02-12:35:36  Initializing virtual root
:2011-06-02-12:35:47  Initializing virtual root
:2011-06-02-12:35:58  Initializing virtual root
:2011-06-02-12:36:09  Initializing virtual root
:2011-06-02-12:36:20  Initializing virtual root
:2011-06-02-12:36:31  Initializing virtual root
:2011-06-02-12:36:42  Initializing virtual root
:2011-06-02-12:36:53  Initializing virtual root
:2011-06-02-12:37:04  Initializing virtual root
:2011-06-02-12:37:15  Initializing virtual root
:2011-06-02-12:37:26  Initializing virtual root
:2011-06-02-12:37:37  Initializing virtual root
:2011-06-02-12:37:48  Initializing virtual root
:2011-06-02-12:37:59  Initializing virtual root
:2011-06-02-12:38:10  Initializing virtual root
:2011-06-02-12:38:21  Initializing virtual root
:2011-06-02-12:38:32  Initializing virtual root
:2011-06-02-12:38:43  Initializing virtual root
:2011-06-02-12:38:54  Initializing virtual root
:2011-06-02-12:39:05  Initializing virtual root
:2011-06-02-12:39:16  Initializing virtual root
:2011-06-02-12:39:27  Initializing virtual root
:2011-06-02-12:39:38  Initializing virtual root
:2011-06-02-12:39:49  Initializing virtual root
:2011-06-02-12:40:00  Initializing virtual root
:2011-06-02-12:40:11  Initializing virtual root
:2011-06-02-12:40:22  Initializing virtual root
:2011-06-02-12:40:33  Initializing virtual root
:2011-06-02-12:40:44  Initializing virtual root
:2011-06-02-12:40:55  Initializing virtual root
:2011-06-02-12:41:06  Initializing virtual root
:2011-06-02-12:41:17  Initializing virtual root
:2011-06-02-12:41:28  Initializing virtual root
:2011-06-02-12:41:39  Initializing virtual root
:2011-06-02-12:41:50  Initializing virtual root
:2011-06-02-12:42:01  Initializing virtual root
:2011-06-02-12:42:12  Initializing virtual root
:2011-06-02-12:42:23  Initializing virtual root
:2011-06-02-12:42:34  Initializing virtual root
:2011-06-02-12:42:45  Initializing virtual root
:2011-06-02-12:42:56  Initializing virtual root
:2011-06-02-12:43:07  Initializing virtual root
:2011-06-02-12:43:18  Initializing virtual root
:2011-06-02-12:43:29  Initializing virtual root
:2011-06-02-12:43:40  Initializing virtual root
:2011-06-02-12:43:51  Initializing virtual root
:2011-06-02-12:44:02  Initializing virtual root
:2011-06-02-12:44:13  Initializing virtual root
:2011-06-02-12:44:24  Initializing virtual root
:2011-06-02-12:44:35  Initializing virtual root
:2011-06-02-12:44:47  Initializing virtual root
:2011-06-02-12:44:58  Initializing virtual root
:2011-06-02-12:45:09  Initializing virtual root
:2011-06-02-12:45:21  Initializing virtual root
:2011-06-02-12:45:32  Initializing virtual root
:2011-06-02-12:45:43  Initializing virtual root
:2011-06-02-12:45:54  Initializing virtual root
:2011-06-02-12:46:04  Initializing virtual root
:2011-06-02-12:46:15  Initializing virtual root
:2011-06-02-12:46:26  Initializing virtual root
:2011-06-02-12:46:40  Initializing virtual root
:2011-06-02-12:46:51  Initializing virtual root
:2011-06-02-12:47:02  Initializing virtual root
:2011-06-02-12:47:13  Initializing virtual root
:2011-06-02-12:47:24  Initializing virtual root
:2011-06-02-12:47:35  Initializing virtual root
:2011-06-02-12:47:46  Initializing virtual root
:2011-06-02-12:47:57  Initializing virtual root
:2011-06-02-12:48:08  Initializing virtual root
:2011-06-02-12:48:19  Initializing virtual root
:2011-06-02-12:48:31  Initializing virtual root
:2011-06-02-12:48:41  Initializing virtual root
:2011-06-02-12:48:52  Initializing virtual root
:2011-06-02-12:49:03  Initializing virtual root
:2011-06-02-12:49:14  Initializing virtual root
:2011-06-02-12:49:25  Initializing virtual root
:2011-06-02-12:49:36  Initializing virtual root
:2011-06-02-12:49:47  Initializing virtual root
:2011-06-02-12:49:58  Initializing virtual root
:2011-06-02-12:50:09  Initializing virtual root
:2011-06-02-12:50:20  Initializing virtual root
:2011-06-02-12:50:31  Initializing virtual root
:2011-06-02-12:50:42  Initializing virtual root
:2011-06-02-12:50:53  Initializing virtual root
:2011-06-02-12:51:04  Initializing virtual root
:2011-06-02-12:51:15  Initializing virtual root
:2011-06-02-12:51:26  Initializing virtual root
:2011-06-02-12:51:37  Initializing virtual root
:2011-06-02-12:51:48  Initializing virtual root
:2011-06-02-12:51:59  Initializing virtual root
:2011-06-02-12:52:10  Generating backtrace
:2011-06-02-12:52:21  Generating backtrace
:2011-06-02-12:52:32  Generating backtrace
:2011-06-02-12:52:43  Generating backtrace
:2011-06-02-12:52:55  Generating backtrace
:2011-06-02-12:53:06  Generating backtrace
:2011-06-02-12:53:17  Cleaning up virtual root
:2011-06-02-12:53:28  Cleaning up virtual root
:2011-06-02-12:53:39  Cleaning up virtual root
:2011-06-02-12:53:50  Cleaning up virtual root
:2011-06-02-12:54:01  Cleaning up virtual root
:2011-06-02-12:54:12  Cleaning up virtual root
:2011-06-02-12:54:23  Cleaning up virtual root
:2011-06-02-12:54:34  Cleaning up virtual root
:2011-06-02-12:54:45  Retrace job finished successfully
Comment 1 Hedayat Vatankhah 2011-06-02 04:48:19 EDT
Created attachment 502458 [details]
File: maps
Comment 2 Hedayat Vatankhah 2011-06-02 04:48:24 EDT
Created attachment 502459 [details]
File: dsos
Comment 3 Hedayat Vatankhah 2011-06-02 04:48:30 EDT
Created attachment 502460 [details]
File: backtrace
Comment 4 Caolan McNamara 2011-06-02 06:33:44 EDT
are you able to reproduce this ?
Comment 5 Caolan McNamara 2011-06-02 06:54:03 EDT
I'll stick in a band-aid to fix the immediate crash, assuming we can trust gdb, but an exact reproducer would allow us to fix it fully.

bandaid will be in >= 3.3.2.2-10
Comment 6 Hedayat Vatankhah 2011-06-02 09:02:42 EDT
Unfortunately, I can't reproduce the problem.
Comment 7 Fedora Update System 2011-06-10 04:40:11 EDT
libreoffice-3.3.2.2-10.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.2.2-10.fc15
Comment 8 Fedora Update System 2011-06-11 00:32:02 EDT
Package libreoffice-3.3.2.2-10.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.3.2.2-10.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libreoffice-3.3.2.2-10.fc15
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-06-15 01:35:49 EDT
libreoffice-3.3.2.2-10.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.