This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 71001 - With focus-follows-mouse set, clicking "taskbar" (Window List) buttons minimizes unraised windows
With focus-follows-mouse set, clicking "taskbar" (Window List) buttons minimi...
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-07 14:20 EDT by Alex Cruise
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 18:44:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing window arrangement (galeon on top of terminal) (155.27 KB, image/png)
2002-08-07 14:22 EDT, Alex Cruise
no flags Details

  None (edit)
Description Alex Cruise 2002-08-07 14:20:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
In GNOME 2.0, with Metacity (at least), when you have focus-follows-mouse
enabled, if your current (focused and raised) window overlaps another window
which is exposed to the south of the current window's border, when you mouse
down to the "taskbar" to choose another task, your mouse will pass over the
obscured window, giving it keyboard focus, before you make your way down to the
taskbar.  But when you click the taskbar button for the window, thinking that
the window will be raised, the window list decides to minimize/iconify the task
instead, because it already has focus. 

Version-Release number of selected component (if applicable):
metacity-2.3.987.92-2
gnome-panel-2.0.2.90-8

How reproducible:
Always

Steps to Reproduce:
0.Configure Metacity to use focus-follows-mouse.
1.Launch any two windows in GNOME 2.0 with Metacity
2.Arrange the windows so that the bottom edge of w2 protrudes below the bottom
edge of w1 when w1 is raised. 
3.With w1 raised and the focus on it, move your mouse downwards toward the
taskbar, crossing over the exposed portion of w2.
4.Click on the taskbar button corresponding to w2.  It will be minimized.
	

Actual Results:  w2 is minimized when it has focus, no matter whether it's raised.

Expected Results:  Clicking a taskbar button should only minimize a window when
it's raised, no matter whether it's focused or not.

Additional info:
Comment 1 Alex Cruise 2002-08-07 14:22:39 EDT
Created attachment 69325 [details]
Screenshot showing window arrangement (galeon on top of terminal)
Comment 2 Havoc Pennington 2002-08-07 14:32:28 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=90134
Comment 3 Havoc Pennington 2003-01-07 18:44:31 EST
Let's just track this one on gnome.org, that's where I deal with metacity 
bugs.

Note You need to log in before you can comment on or make changes to this bug.