Bug 710022 - yum tracebacks with rhn.rpclib.InvalidRedirectionError: HTTPS redirected to HTTP is not supported
yum tracebacks with rhn.rpclib.InvalidRedirectionError: HTTPS redirected to H...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.7
All Linux
high Severity high
: rc
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
: 710044 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-02 05:44 EDT by Miroslav Vadkerti
Modified: 2011-06-03 07:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-03 07:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Vadkerti 2011-06-02 05:44:19 EDT
Description of problem:
Looks like the RHN server has some issues (serverURL=https://xmlrpc.rhn.redhat.com/XMLRPC) and this causes rhn plugin to traceback. I think this should not happen and an error message should be printed instead of a traceback.

Machine I can now reproduce this 100%:
ppcp-5s-m1.ss.eng.bos.redhat.com

# yum -y update
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data,
              : keys, kmod, list-data, protect-packages, protectbase, rhnplugin,
              : security, tmprepo, verify, versionlock
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 157, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 187, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 665, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 254, in _getConfig
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 111, in init_hook
    login_info = up2dateAuth.getLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 219, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 186, in login
    li = server.up2date.login(systemId)
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 50, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 204, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 38, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 425, in _request
    raise InvalidRedirectionError(
rhn.rpclib.InvalidRedirectionError: HTTPS redirected to HTTP is not supported


Version-Release number of selected component (if applicable):
rhn-client-tools-0.4.20-46.el5.noarch

How reproducible:
100% (now)

Steps to Reproduce:
enabled rhn plugin
1. yum -y update
2. yum repolist
  
Actual results:
traceback

Expected results:
error message
Comment 1 Miroslav Vadkerti 2011-06-02 05:49:47 EDT
This currently happens on all machines subscribed to rhn.redhat.com (LIVE)
Comment 2 Šimon Lukašík 2011-06-02 08:03:35 EDT
*** Bug 710044 has been marked as a duplicate of this bug. ***
Comment 3 Milan Zazrivec 2011-06-03 04:48:25 EDT
Do these systems have location aware update (aka Akamai) enabled?
Comment 4 Milan Zazrivec 2011-06-03 07:08:21 EDT
This seems to have been a temporary problem with Akamai -> closing.

Note You need to log in before you can comment on or make changes to this bug.