Bug 71005 - Feature Request: add xbindkeys for future releases
Summary: Feature Request: add xbindkeys for future releases
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-keyboard (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-07 19:11 UTC by Jef Spaleta
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-23 05:11:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jef Spaleta 2002-08-07 19:11:35 UTC
I'm not sure where to place this feature request, but rawhide seems the most
logical spot.  I don't know of another program currently in rawhide that supports
multimedia keyboards, so I thought I'd suggest xbindkeys.  I've been using
xbindkeys for a while to make my extra set of multimedia keys on my keyboard
somewhat functional, not as functional as adding a new xkeyboard map specific to
my keyboard...but definitely much easier to setup.

http://hocwp.free.fr/xbindkeys/xbindkeys.html

it even has a gtk based gui config tool.
http://www.netchampagne.com/xbindkeys_config/

Comment 1 Brent Fox 2002-11-18 17:42:18 UTC
I've wanted to do get people's extra keyboard buttons to work for some time now,
but the UI for XBindKeys looks overly complicated.  

So there's two parts to the problem.  One is getting the keyboard properly
configured so that the OS gets signals from these extra keys.  That should be
the job of redhat-config-keyboard.

The other part is associating actions with those extra keys.  It seems to me
that the place to do that is the gnome-keybinding-properties.  I'll change the
component of this report to redhat-config-keyboard since we plan on removing
kbdconfig in the next release.

Comment 2 Brent Fox 2002-12-23 05:11:00 UTC
Deferring since this isn't going to happen for this release.


Note You need to log in before you can comment on or make changes to this bug.