Bug 71014 - update iso8859-{1,15} composition rules to match en_US.UTF8 ones
Summary: update iso8859-{1,15} composition rules to match en_US.UTF8 ones
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: limbo
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 70995
TreeView+ depends on / blocked
 
Reported: 2002-08-07 20:05 UTC by Alexandre Oliva
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 20:09:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes the problems in XFree86-4.2.0-56. (2.71 KB, patch)
2002-08-07 20:09 UTC, Alexandre Oliva
no flags Details | Diff

Description Alexandre Oliva 2002-08-07 20:05:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
Currently, iso8859-15 and iso8859-1 differ in handling of <dead_diaeresis>
<space>: the former generates quotedbl, and the letter produces diaeresis. 
Since <dead_diaeresis> <dead_diaeresis> already generates diaeresis and there's
no other easy way to generate quotedbl, the choice of en_US.UTF8 and iso8859-15
of generating quotedbl for the <dead_diaeresis> <space> composition looks sane,
so I'd like it to make it to iso8859-1 too.

Also, the iso8859-1 and iso8859-15 differ from en_US.UTF8 in a few double-accent
and accent-space pairs in that there are duplicates, sometimes conflicting ones,
in the iso8859 files.

The patch I'm attaching here, that I'm submitting to XFree86 too, should fix
these problems.

Comment 1 Alexandre Oliva 2002-08-07 20:09:03 UTC
Created attachment 69344 [details]
Patch that fixes the problems in XFree86-4.2.0-56.

Comment 2 Mike A. Harris 2002-08-07 22:16:07 UTC
Patch applied to XFree86 4.2.0-60.3


Note You need to log in before you can comment on or make changes to this bug.