This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 710149 - Subscription Assistant button is removed once you are fully entitled?
Subscription Assistant button is removed once you are fully entitled?
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Devan Goodwin
J.C. Molet
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-06-02 10:34 EDT by J.C. Molet
Modified: 2011-12-06 12:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:14:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2011-06-02 10:34:17 EDT
Description of problem:
Given that the subscription assistant has the ability to subscribe to future entitlements, shouldn't the button to access it always be visible?

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.96.1-1.git.197.bc2adc9.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.  Find a box with subscription manager
2.  have a product cert on it
3.  subscribe to a entitlement that satisfies that product
  
Actual results:
The Subscription Assistant button goes away

Expected results:
The subscription Assistant button is always accessible.

Additional info:
This contributes to confusion (see https://bugzilla.redhat.com/show_bug.cgi?id=676371#c6 and bug 710077)
Comment 1 Devan Goodwin 2011-08-03 15:39:57 EDT
Fixed in a2d60c6ba104155daf71de41bd9e0569d40ba2a9 but the compliance assistant seems pretty broken once you start doing this. Adding more bugs now.
Comment 2 J.C. Molet 2011-08-08 11:14:40 EDT
subscription-manager-gnome-0.96.5-1.git.6.680bb38.el6.x86_64

Update Certificates button is now always visible.  If not registered it properly asks you to register when you click on it.

Moving to VERIFIED.
Comment 3 errata-xmlrpc 2011-12-06 12:14:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.