Bug 71022 - pthread_cond_wait() misses cancel signal
pthread_cond_wait() misses cancel signal
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-07 17:34 EDT by Julian Chang
Modified: 2016-11-24 09:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 17:25:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test program (617 bytes, text/plain)
2002-08-07 17:36 EDT, Julian Chang
no flags Details
shell script used to exercise test program (68 bytes, text/plain)
2002-08-07 17:37 EDT, Julian Chang
no flags Details

  None (edit)
Description Julian Chang 2002-08-07 17:34:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
I am porting an application from RHL7.0 to RHL7.2 and I am having problems 
exiting because an associated detached thread seems to be hanging in 
pthread_cond_wait().  Sample test program and shell script are attached.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.compile test program
2.run shell script
3.
	

Actual Results:  test program will hang after 10-50 iterations

Expected Results:  test program should always exit cleanly

Additional info:

gcc is 2.96-108.7.2
glibc is 2.2.4-27
Comment 1 Julian Chang 2002-08-07 17:36:30 EDT
Created attachment 69384 [details]
test program
Comment 2 Julian Chang 2002-08-07 17:37:40 EDT
Created attachment 69385 [details]
shell script used to exercise test program
Comment 3 Alan Cox 2002-12-15 17:25:42 EST
Works for me in 8.0

Note You need to log in before you can comment on or make changes to this bug.