Bug 710231 - CUPS says print job is complete, but nothing came out of printer.
Summary: CUPS says print job is complete, but nothing came out of printer.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-02 18:38 UTC by Bob Gustafson
Modified: 2011-08-12 18:19 UTC (History)
2 users (show)

Fixed In Version: system-config-printer-1.3.5-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-12 10:57:52 UTC
Type: ---


Attachments (Terms of Use)
Screen dump of CUPS - completed jobs (38.94 KB, image/jpeg)
2011-06-02 18:40 UTC, Bob Gustafson
no flags Details
Packet Exchange between computer and printer. (74.34 KB, application/octet-stream)
2011-06-02 18:46 UTC, Bob Gustafson
no flags Details


Links
System ID Private Priority Status Summary Last Updated
CUPS Bugs and Features 3871 0 None None None Never

Description Bob Gustafson 2011-06-02 18:38:23 UTC
Description of problem:

This is an erratic problem. Sometimes it is there, sometimes not.

I print an email. The printer does not blink or growl (old HP 2100 TNM).


Version-Release number of selected component (if applicable):

 CUPS 1.4.6 (from http://localhost:631/

How reproducible:

  Not always, but when it doesn't want to print, all subsequent print requests from that computer have same behavior.

Steps to Reproduce:
1. Print an email (Evolution, select email and click printer icon)
2. Turn to printer, expecting to see blinking green light.
3. Printer light solid green, no blinking.
4. I go into http://localhost:631/
Administrators
  Adding Printers and Classes
    Manage Printers
     Select LaserJet
       Click Show Completed Jobs (see attachment)

The email shows as Completed, however, no blinking green lights, no growl, no printed page.

So, what to do other than reboot?

My wife has a PowerMac on the same network, looking at the same mail server (Dovecot on another machine), I found the email, selected it and then printed it successfully from the Mac.

-----

This problem has happened to me before, about once a month or so - usually when I really need that hardcopy (airline check-in page..).

I usually delete the printer and re-add the printer and otherwise do violent things with the queues, etc. Usually I can then print.

-----

It may be a protocol problem. Under some conditions, the print driver in this computer thinks it has sent (ahh - I can put up wireshark to see if anything was sent - will do now)

Hmm, packets are going to printer. Starts off with TCP, then SNMP, then TCP, then SNMP. See attached .pcap file.


Actual results:

  No printer output, No status light change on printer.

Expected results:

  Blinking green light on printer, then growl, then printed page comes out

Additional info:

  Yes, there is paper in the printer.

Comment 1 Bob Gustafson 2011-06-02 18:40:38 UTC
Created attachment 502604 [details]
Screen dump of CUPS - completed jobs

This is screen image of CUPS 'completed jobs' showing attempts at printing an email

Comment 2 Bob Gustafson 2011-06-02 18:46:35 UTC
Created attachment 502610 [details]
Packet Exchange between computer and printer.

This is complete exchange between computer and printer. An email was printed, but nothing came out of printer. The file format is libpcap (wireshark readable).

(not the same email as before)

Comment 3 Tim Waugh 2011-06-13 11:31:40 UTC
Nothing looks untoward from the packet capture.  The printer isn't reporting any kind of error.  When you try printing something and it fails, will it always reliably fail for that particular file?

Maybe try a different driver.  Both HPLIP and gutenprint provide drivers for this printer, as well as there being several "legacy" drivers built into ghostscript.

Run "system-config-printer" to change to a different driver.

Comment 4 Bob Gustafson 2011-06-13 17:48:51 UTC
1) Printing the first page of this bugreport works. This is Firefox 4.01 and the print driver currently being used is:

  (from Applications->Other->Printing - hmm doesn't seem to identify driver)

  The printer is an old HP LaserJet 2100M F... This could be foomatic..

  The printer contains a built in Postscript interpreter
   (Level 2 emulation according to the native test page)

  Communication with the printer is socket://192.168.49.5:9100

2) Printing does not work when I try to print an email from Evolution 3.0.2
   The symptoms are as detailed earlier. CUPS thinks it has completed,
   green light blinks for awhile on printer, then solid green (idle) and
   no paper comes out.

3) At some point in my earlier experiments (changing drivers maybe), I did see an almost blank page come out with the message:
   This print job requires a PostScript Language Level 3 printer.

What do you suggest I try next?

Comment 5 Tim Waugh 2011-06-14 10:41:22 UTC
In the printer properties dialog window, see what it says next to "Make and Model:".  That string identifies the driver.

Click the 'Change...' button immediately next to that to see the alternatives.

In particular, try the HPLIP one:

HP LaserJet 2100, hpcups 3.11.5 [en]

which is the one suggested here:
http://www.openprinting.org/printer/HP/HP-LaserJet_2100M

Comment 6 Bob Gustafson 2011-06-14 12:58:03 UTC
Applications->System Tools->System Settings->Printers

   doesn't show much of anything

Applications->Other->Printing->Select Printer->Properties

  If I stretch out the window to make it wider, the

  Make and Model: HP LaserJet 2100M Foomatic/Postscript

  shows. I had given it above, but did not stretch out window..

-----

Under choices - there are many... I select hpcups 3.11.5 [en]

There is an additional choice on the next Forward:

    Use the new PPD as is:

  x Try to copy the option settings over from the old PPD

Next Forward - no duplexer, so did not choose this option.

Apply

--------

Testing - YES, it can print your email from Evolution as 'Job #4'

-------

However, when I click the Print Test Page on the Printer Properties Page, it queues up the test page as 'job 23' and then a notification pops up in the upper right corner of the screen - printer not connected.

When I put paper in the printer, it does print a rudimentary test page. Does not mention resolution or memory.

------

Thanks much, the hpcups 3.11.5 [en] driver seems to do the job.

Comment 7 Tim Waugh 2011-06-14 14:32:23 UTC
Actually it looks like the foomatic-db package we are shipping already says to use the pxlmono driver, so I wonder why that isn't happening.

Could you please run this command and show the output?:

/usr/lib/cups/backend/snmp 192.168.49.5

Thanks.

Comment 8 Bob Gustafson 2011-06-14 15:34:52 UTC
[user1@hoho6 ~]$ /usr/lib/cups/backend/snmp 192.168.49.5
network socket://192.168.49.5 "HP LaserJet 2100 Series" "HP LaserJet 2100 Series" "MANUFACTURER:Hewlett-Packard;COMMAND SET:PJL,MLC,PCL,PCLXL,POSTSCRIPT;MODEL:HP LaserJet 2100 Series;CLASS:PRINTER;DESCRIPTION:Hewlett-Packard LaserJet 2100 Series" ""
[user1@hoho6 ~]$

Comment 9 Tim Waugh 2011-06-21 14:51:57 UTC
One thing that isn't helping at all here is that the foomatic recommendation is being lost due to cupsd truncating the PPD's Device ID.  I've filed STR #3871 upstream to track that.

Comment 10 Tim Waugh 2011-06-21 15:14:50 UTC
The next part of the problem is that system-config-printer deliberately ignores any foomatic recommendation to use pxlmono specifically.  The reason for this is to work around bug #661814.

In this case, though, the foomatic recommendation is irrelevant: we simply want to avoid using a PostScript driver.

Accordingly, I've updated our preference rules to avoid PostScript drivers by preference for this particular model.

Fixed upstream in c0d44ce.

Comment 11 Bob Gustafson 2011-06-21 15:35:20 UTC
I rather liked my original title/summary line:

CUPS says print job is complete, but nothing came out of printer.

Comment 12 Tim Waugh 2011-06-21 15:45:23 UTC
Feel free to change it back if you like... it describes a symptom, not the cause.

Comment 13 Bob Gustafson 2011-06-24 15:00:05 UTC
My reasoning is that folks looking at bugs know their symptom. They then read the bug report to find the cause.

If you know the cause, you don't need the bug report..

Comment 14 Fedora Update System 2011-07-18 11:34:33 UTC
system-config-printer-1.3.4-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-config-printer-1.3.4-1.fc15

Comment 15 Fedora Update System 2011-07-18 22:26:23 UTC
Package system-config-printer-1.3.4-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.3.4-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-printer-1.3.4-1.fc15
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2011-07-31 03:49:14 UTC
Package system-config-printer-1.3.5-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.3.5-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-printer-1.3.5-1.fc15
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2011-08-02 02:01:53 UTC
Package system-config-printer-1.3.5-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.3.5-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-printer-1.3.5-2.fc15
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2011-08-03 02:30:48 UTC
Package system-config-printer-1.3.5-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.3.5-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-printer-1.3.5-3.fc15
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2011-08-12 10:56:53 UTC
system-config-printer-1.3.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2011-08-12 18:18:10 UTC
system-config-printer-1.3.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.