This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 710293 - [Calistoga] i915 can't handle dual screen GNOME 3
[Calistoga] i915 can't handle dual screen GNOME 3
Status: CLOSED DUPLICATE of bug 699705
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-02 18:19 EDT by Richard Schwarting
Modified: 2011-06-06 11:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-06 11:08:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (61.95 KB, text/plain)
2011-06-02 18:21 EDT, Richard Schwarting
no flags Details

  None (edit)
Description Richard Schwarting 2011-06-02 18:19:55 EDT
Description of problem:
I have a Compaq tc4400 using i915 in the kernel for the graphics controller:
Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller

When I run GNOME 3 normally, it is accelerated, and works at 1024x768.  It is pleasant and nice and responsive.

If I plug in my second monitor, the screen successfully paints across the length.  However, everything is incredibly unresponsive and slow, and there is a lot of diagonal tearing when windows move or open or close.  It isn't useable. 

In xorg.0.log, when changing to two monitors, I note this:
[126005.494] (WW) intel(0): Failed to set tiling on frontbuffer.
[126005.494] (II) intel(0): Allocated new frame buffer 2944x1293 stride 11776, untiled

When I switch back to just my laptop's LCD, I see this:
[126232.348] (II) intel(0): Allocated new frame buffer 1024x768 stride 4096, tiled

I was able to use my second monitor with Fedora 14 (using GNOME Panel and Metacity or Compiz) fine.  (I think Compiz worked fine.  I'm actually kind of fuzzy on that memory.)


Version-Release number of selected component (if applicable):
xorg-x11-drv-intel: 2.15.0-3
kernel: 2.6.38.6-27

How reproducible:
Always, whenever I plug in the second monitor.

Steps to Reproduce:
1. upgrade to Fedora 15 and use GNOME Shell
2. plug in a second monitor
3.
  
Actual results:
Responsiveness slows to a crawl, though at least everything is drawn eventually.  There is tearing on windows.

Expected results:
Responsiveness remains constant and good.

Additional info:
I wonder whether my video card won't be able to handle GNOME 3 with a second monitor.  :|
Comment 1 Richard Schwarting 2011-06-02 18:21:14 EDT
Created attachment 502667 [details]
Xorg.0.log
Comment 2 Adam Jackson 2011-06-06 11:08:34 EDT

*** This bug has been marked as a duplicate of bug 699705 ***

Note You need to log in before you can comment on or make changes to this bug.