Bug 710315 - named goes into busy loop if working directory not writable
named goes into busy loop if working directory not writable
Status: CLOSED DUPLICATE of bug 709205
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
14
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-02 22:32 EDT by Matthew Gillen
Modified: 2013-04-30 19:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-08 05:03:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Gillen 2011-06-02 22:32:24 EDT
Description of problem:
I updated bind today (to version 9.7.4-0.1.b1.fc14), and when I restarted named, my CPU usage went to 100% (top confirmed 'named' was using as much available CPU time on a single processor as it could).  /var/log/messages had this line after the restart:
 named[9713]: the working directory is not writable

The permissions on /var/named were:
drwxr-x---. 5 root named 4096 Jun  2 15:35 /var/named/

Adding group-write permissions to that directory made the problem go away (i.e. named now uses a sane amount of CPU time).  

Version-Release number of selected component (if applicable):
9.7.4-0.1.b1.fc14

How reproducible:
Make /var/named not writable by the named user
Comment 1 Daniel Veillard 2011-06-05 23:03:35 EDT
I got that too on a couple of F14 machines apparently after update to
bind-9.7.4-0.1.b1.fc14.x86_64

Changing the permissions as indicated seems to fix this,

Daniel
Comment 2 Adam Tkac 2011-06-08 05:03:11 EDT

*** This bug has been marked as a duplicate of bug 709205 ***

Note You need to log in before you can comment on or make changes to this bug.