Bug 7105 - Wrong amount of memory found for Dell Dimension L400c
Summary: Wrong amount of memory found for Dell Dimension L400c
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-18 17:08 UTC by rouillardj
Modified: 2018-01-11 21:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-25 19:04:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rouillardj 1999-11-18 17:08:37 UTC
On bootup, the computer (bios) says that it has 64MB of ram, and 1 64MB
DIMM chip is installed. When the 6.0 or 6.1 (original 6.1, not the RHEA
boot images) bootable install CD's  start up, they only find 16MB. After
the system is installed and booting from the hard drive /proc/meminfo
still shows only 16 MB.

If I try booting with "linux mem=64m" the systems crashes before as the
first filesystem is loaded. I can make it boot with "linux mem=62m" but
why isn't it finding all of the installed memory in the first place?

Since these machines are going to be servers, I really don't want the
systems to crash because of memory (available/usable vs specified)
issues.

Wasn't the 6.1 release supposed to detect memory past (and one would
believe up to) the 64MB limit?

I have tested this on two identical boxes, so I don't belive that it is a
hardware problem (unless the hardware problem is identical as well 8-)).
Then again, it the bios (rev. A01) in these boxes could be really screwy.

-- rouilj

Comment 1 Cristian Gafton 2000-01-04 22:26:59 UTC
Assigned to dledford

Comment 2 Isaac Salsberg 2000-04-25 19:04:59 UTC
I'm having the same problem with an assembled machine. It has 128 mb but in red
hat I only could see 64mb. The machine uses the AMD Athlon CPU.

Booting the computer with the trick  rouilj said, I can see up to 120 mb. The
other 8 mb are used by the integrated video card.  I added the option to the
lilo.conf file in order to avoid typing it every time the machine boots.

Isaac

Comment 3 Alan Cox 2000-08-08 15:10:20 UTC
This is vendor BIOS problems not kernel. Linux 2.2 supports E801 large memory
queries. 2.4 supports the E820 stuff which helps for some of these vendor
problems

Comment 4 openshift-github-bot 2018-01-11 21:01:39 UTC
Commits pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/973c71946bfbe263bdf0bda52b7054749f7c7fa4
Issue 7105, removed   from cluster resource override example

https://github.com/openshift/openshift-docs/commit/c695e5b91b9d739b17ae6c387b1b341459ec0d1b
Merge pull request #7106 from ahardin-rh/overcommit-fix

Issue 7105, removed  kubernetesMasterConfig from cluster resource override example


Note You need to log in before you can comment on or make changes to this bug.