Bug 71051 - truetype fonts don't work in some apps
Summary: truetype fonts don't work in some apps
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-08 10:32 UTC by Tim Waugh
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 12:12:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2002-08-08 10:32:57 UTC
Description of Problem:   
With some extra truetype fonts installed, and xfs told about them, some apps  
can't use them.  But I don't know there the bug is.  
  
xfontsel can display the fonts okay, but (for example) gimp can't, and  
OpenOffice can't display all of them.  The set of fonts that work seems to be  
different depending on the app.  But xfontsel seems to be happy with them all.  
  
I tried this experiment, to try to figure out where the problem is:  
  
1. Install a 6.2 machine, and install some truetype fonts on it.  
2. Fire up gimp (1.0), try to use the fonts.  This works. 
3. Set the DISPLAY to point to the X server on a Limbo2 machine and start 
gimp. 
4. Try to use the fonts.  This doesn't work. 
5. Then run gimp from Milan (1.2) with its display set to the 6.2 machine. 
6. Try to use the fonts.  This doesn't work. 
 
ISTR this behaviour being the same for the last few releases, in that some 
fonts that used to work no longer do. 
 
Any ideas?

Comment 1 Owen Taylor 2002-08-08 16:41:57 UTC
Assigning to XFree86, since fontconfig has nothing to do with the fonts
that xfs reports.

What fonts in particular aren't working? I'd guess it has something
to do with encodings, maybe.

Comment 2 Tim Waugh 2002-08-08 16:49:29 UTC
For example Dragonmaster from http://www.brrp.net/fonts.htm.

Comment 3 Mike A. Harris 2002-08-09 23:19:59 UTC
Step one says "Install a 6.2 machine"..  Am I to assume you mean
Red Hat Linux 6.2?

Comment 4 Tim Waugh 2002-08-10 11:03:06 UTC
Yes of course.

Comment 5 Mike A. Harris 2002-08-12 12:12:09 UTC
If xfontsel can display the fonts, then the fonts are available
to X applications.  I don't see it as an XFree86 bug in this case.

They're being served by the font server.

If an application is GNOME/KDE/GTK/QT based, we have antialiasing
enabled by default.  In this case Xft2 is used for fonts, and XFree86
and xfs are out of the picture.

Anyone else have any suggestion for this?

Comment 6 Tim Waugh 2002-09-10 13:43:54 UTC
Mysterious, this works fine with current rawhide.


Note You need to log in before you can comment on or make changes to this bug.