Bug 71054 - mkinitrd does not handle LABEL partitions in fstab
mkinitrd does not handle LABEL partitions in fstab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-08 06:58 EDT by Andrea Sterbini
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 06:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrea Sterbini 2002-08-08 06:58:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

Description of problem:
When I install a newew kernel in my RH 7.3 the initrd file created does not
work. This because I use LABEL for my root partition and mkinitrd does not
handle the LABEL properly in fstab.

The system works fine only if I avoid labeling my root partition.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
0. keep configured a good old version of kernel for rebooting later....
BEWARE: if you don't you will not boot again!
1. label your root partition in the fstab file
2. use mkinitrd to produce the new initrd
3. reboot
	

Actual Results:  Kernel panic because the root partition is not found

Expected Results:  normal boot

Additional info:
Comment 1 Erik Troan 2002-11-05 16:52:04 EST
works in 8.0 -- new mkinitrd should be all you need

Note You need to log in before you can comment on or make changes to this bug.