Bug 710547 - Closing laptop lid suspends, but does not lock the screen.
Closing laptop lid suspends, but does not lock the screen.
Status: CLOSED DUPLICATE of bug 708543
Product: Fedora
Classification: Fedora
Component: gnome-desktop3 (Show other bugs)
15
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-03 12:39 EDT by Phil Barnes
Modified: 2011-06-28 08:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 08:50:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phil Barnes 2011-06-03 12:39:40 EDT
Description of problem:
Closing laptop lid suspends, but does not lock the screen.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Close laptop lid.
2. Wait a few seconds.
3. Open lid.
4. Laptop returns from suspend, but screen is not locked. i.e. there is no password prompt as there was in previous versions.
  
Actual results:
Laptop returns from suspend, but screen is not locked. i.e. there is no password prompt as there was in previous versions.

Expected results:
Locked screen requiring password.

Additional info:
Comment 1 Sebastian Krämer 2011-06-04 06:41:56 EDT
Does this also happen without suspend?
For me, the problem is that the screen blanking kicks in at some point but it doesn't get locked. (It happens with suspend, too, but not only there.)

gnome-control-center -> display  has the locking functionality checked "ON".

gnome-screensaver-3.0.0-1.fc15.x86_64
Comment 2 Sebastian Krämer 2011-06-04 06:43:49 EDT
Btw., duplicate of #708543?
Comment 3 Steve Sauls 2011-06-07 21:29:09 EDT
I can confirm this bug.  The laptop suspends fine and all power management features work great.  But there is no lock on suspend.

However as a work around just manually lock the screen before closing the lid.
Comment 4 Steve Sauls 2011-06-07 21:34:12 EDT
I can also confirm that the suspend feature from the pull down menu under user name in top right corner will suspend and lock the laptop.

But when closing the lid it will suspend but will "NOT" lock the laptop.
Comment 5 Steve Sauls 2011-06-07 21:35:41 EDT
(In reply to comment #4)
> I can also confirm that the suspend feature from the pull down menu under user
> name in top right corner will suspend and lock the laptop.
> 
> But when closing the lid it will suspend but will "NOT" lock the laptop.

In addition you actually could manually suspend the laptop and then close the lid.  this will lock the screen upon waking.
Comment 6 Nicola Soranzo 2011-06-28 08:50:32 EDT

*** This bug has been marked as a duplicate of bug 708543 ***

Note You need to log in before you can comment on or make changes to this bug.