Bug 710586 - [abrt] guake-0.4.2-3.fc15: guake.py:649:__init__:GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
Summary: [abrt] guake-0.4.2-3.fc15: guake.py:649:__init__:GError: GDBus.Error:org.free...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: guake
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pierre-YvesChibon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:19df04750b9d5cf42e5fefb49f6...
: 751791 759271 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-03 19:34 UTC by Marcelo Cardozo
Modified: 2012-04-23 22:53 UTC (History)
12 users (show)

Fixed In Version: guake-0.4.2-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-10 21:54:48 UTC


Attachments (Terms of Use)
patch to avoid using the notification system if it is not working (1.68 KB, patch)
2012-02-25 00:06 UTC, Enrique
no flags Details | Diff

Description Marcelo Cardozo 2011-06-03 19:34:02 UTC
abrt version: 2.0.1
architecture:   i686
cmdline:        
comment:        luego de la ultima actualizacion de Fedora 15
component:      guake
executable:     /usr/lib/guake/guake.py
kernel:         2.6.38.6-27.fc15.i686.PAE
os_release:     Fedora release 15 (Lovelock)
package:        guake-0.4.2-3.fc15
reason:         guake.py:649:__init__:GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
time:           Fri Jun  3 16:33:24 2011
uid:            500
username:       mcardozo

backtrace:
:guake.py:649:__init__:GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
:
:Traceback (most recent call last):
:  File "/usr/lib/guake/guake.py", line 1353, in <module>
:    if not main():
:  File "/usr/lib/guake/guake.py", line 1296, in main
:    instance = Guake()
:  File "/usr/lib/guake/guake.py", line 649, in __init__
:    notification.show()
:GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
:
:Local variables in innermost frame:
:keyval: 65481
:colormap: <gtk.gdk.Colormap object at 0x9d42cfc (GdkColormap at 0x9c35ce0)>
:img: '/usr/share/pixmaps/guake/guake-tray.png'
:evtbox: <gtk.EventBox object at 0x9d42694 (GtkEventBox at 0x9c35a48)>
:notification: <pynotify.Notification object at 0x9d49414 (NotifyNotification at 0x9deb550)>
:screen: <gtk.gdk.ScreenX11 object at 0x9d42cd4 (GdkScreenX11 at 0x9c300f0)>
:mask: <flags 0 of type GdkModifierType>
:label: 'F12'
:ipath: '/usr/share/pixmaps/guake/add_tab.png'
:hide_context_menu: <function hide_context_menu at 0x9d468ec>
:key: 'F12'
:destroy: <function destroy at 0x9d4695c>
:filename: '/usr/share/pixmaps/guake/guake-notification.png'
:self: Guake(path="/usr/share/guake/guake.glade")
:double_click: <function double_click at 0x9d46994>

Comment 1 Brandon 2011-06-07 17:15:17 UTC
Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Started an LXDE session

Comment 2 Pierre-YvesChibon 2011-06-14 13:41:02 UTC
Sorry for the late answer. Could you provide me with a bit more info as to how
it happened ?
Can you reproduce it ?

Thanks for reporting it =)

Comment 3 Marcelo Cardozo 2011-06-14 13:48:27 UTC
Hi Pierre
I can't reproduce the issue, because is intalled on produccion machine.
I reinstall Fedora 15 to resolve the problem. I know that this issue is related with a bug in User-Theme extension that broke when using  GNOME Shell Themeselector or Tweak Tool(my case).
Actually i don't install any extension related with UI change becuse a need the machine online.

Thanks for your time.

Comment 4 Pierre-YvesChibon 2011-06-14 13:58:10 UTC
If I understand you correctly, it is not a bug on Guake :-)
Then the bug should be closed/re-assigned.

Let's see if Brandon can still reproduce the bug, otherwise I'd propose that we close it.

Comment 5 Enrique 2011-07-27 09:20:35 UTC
Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I just started guake, but it never showed up and abrt showed there was a crash.
 I am using the Xfce environment.

Comment 6 Pierre-YvesChibon 2011-08-10 13:13:05 UTC
This seems to be a xfce specific behaviour which can be solved simply by installing "xfce4-notifyd".

I am however not sure whether I should make guake requiring it.

Comment 7 Enrique 2011-08-19 15:42:42 UTC
 Installing 'xfce4-notifyd' "solves" indeed the problem. However, I think that guake shouldn't crash if this package is missing. Since the notifications is probably an optional feature, a segmentation fault if the notification service is not running is not the desired behavior.
 In any case, I agree that guake shouldn't depend on xfce4-notifyd.
  Regards!

Comment 8 Pierre-YvesChibon 2011-08-21 21:29:49 UTC
It is the default behavior of guake to display a small notification message once started (helping the user to see that guake is running).

This can be deactivated on the preferences window.

Comment 9 Enrique 2011-09-08 14:38:22 UTC
 Well, the "bug" prevents guake from being started, so one can hardly use the preferences window... My point is, can guake check the presence of the notification system before displaying the message?

 Regards

Comment 10 Pierre-YvesChibon 2011-09-15 11:03:39 UTC
You can access guake's preference through the menu or "guake -p".

As for your question, it's a good one, I'll have to check with upstream.

Comment 11 Julius B. 2011-10-24 14:47:33 UTC
Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
1. Install guake
2. Run guake (via ALT+F2)

Comment 12 Julius B. 2011-10-24 14:56:56 UTC
Using LXDE, I'm having the same problem. Installing xfce4-notifyd is no solution since it pulls a few xfce4 packages which I don't want. Is there an equivalent for LXDE powered desktops?

Comment 13 Pierre-YvesChibon 2011-11-07 15:25:26 UTC
*** Bug 751791 has been marked as a duplicate of this bug. ***

Comment 14 michael.mcconachie 2011-11-07 15:37:55 UTC
I submitted this same bug, via the auto reporting tool (I wish the bug reporting tool would do a search on BZ before sending stuff out) which apparently was a duplicate issue; I also remember having to install "xfce4-notifyd" when I was using guake with XFCE in FC15.  I should have remembered, my apologies for submitting a duplicate.  Thanks all!

Comment 15 michael.mcconachie 2011-11-07 15:43:34 UTC
(In reply to comment #12)
> Using LXDE, I'm having the same problem. Installing xfce4-notifyd is no
> solution since it pulls a few xfce4 packages which I don't want. Is there an
> equivalent for LXDE powered desktops?

I'm using LXDE as I type this (on beta FC16_64) -- I installed "xfce4-notifyd" which only installed a total of 4 packages (3 of them deps); they totaled 456 KB.  

- libxfce4util
- xconf
- libxfce4ui
- xfce4-notifyd

Are you getting more than that when you attempt to install it?

Thanks

Comment 16 Pierre-YvesChibon 2011-11-07 15:45:57 UTC
(In reply to comment #15)
> (In reply to comment #12)
> > Using LXDE, I'm having the same problem. Installing xfce4-notifyd is no
> > solution since it pulls a few xfce4 packages which I don't want. Is there an
> > equivalent for LXDE powered desktops?
> 
> I'm using LXDE as I type this (on beta FC16_64) -- I installed "xfce4-notifyd"
> which only installed a total of 4 packages (3 of them deps); they totaled 456
> KB.  

Did it fix guake's problem as well ?

Comment 17 michael.mcconachie 2011-11-07 15:54:48 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > (In reply to comment #12)
> > > Using LXDE, I'm having the same problem. Installing xfce4-notifyd is no
> > > solution since it pulls a few xfce4 packages which I don't want. Is there an
> > > equivalent for LXDE powered desktops?
> > 
> > I'm using LXDE as I type this (on beta FC16_64) -- I installed "xfce4-notifyd"
> > which only installed a total of 4 packages (3 of them deps); they totaled 456
> > KB.  
> 
> Did it fix guake's problem as well ?

From what I can tell; I can actuate guake with F12, and set it's preferences after installing the missing dep. in my LXDE environment with no errors, or noticeable slowness/performance issues.  I'd say mark it as closed :)

Comment 18 sly 2011-11-13 19:01:11 UTC
Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
installed it using yum
ran it the first time
crash

Comment 19 Pierre-YvesChibon 2011-12-01 09:28:24 UTC
I will try blog about this and we will close this bug then :)

Comment 20 Pierre-YvesChibon 2011-12-01 20:43:30 UTC
*** Bug 759271 has been marked as a duplicate of this bug. ***

Comment 21 recyber 2011-12-17 19:09:22 UTC
i have just installed guake terminal

rating: (null)
Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment 22 michael 2011-12-27 09:26:36 UTC
logged in to lxde desktop and it crashed right awat.			

rating: (null)
Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment 23 jckenny02 2012-02-18 16:03:20 UTC
I installed the Fedora 16 LXDE x86_64 spin to my hard drive. On first boot, I upgraded all of my packages using "yum upgrade". Before rebooting, I installed guake via "yum install guake". Then I immediately rebooted. After reboot, guake produced this error.

Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment 24 michael.mcconachie 2012-02-18 19:43:18 UTC
Jeez all,

...does anyone read anymore before posting bugs?  All you have to do is look up-thread 4-5 comments, and the solution has been posted there for months.

Please yum install "xfce4-notifyd" to fix the problem.  

Let me know if this doesn't work.

Mike

Comment 25 jckenny02 2012-02-20 04:31:26 UTC
Yep, Guake stopped crashing after installing xfce4-notifyd.

Comment 26 michael.mcconachie 2012-02-20 05:27:13 UTC
Can we mark this as resolved please?

Comment 27 jckenny02 2012-02-22 03:30:23 UTC
Manually installing xfce4-notifyd is a workaround, not a resolution. The guake package should be updated so that xfce4-notifyd is a required dependency or it needs to fixed so that it doesn't crash if xfce4-notifyd isn't installed.

Comment 28 michael.mcconachie 2012-02-22 03:38:27 UTC
Totally agree.  I thought about that after I hit "send" on the last message.  Thanks for the comment.  Now, to convince someone to do this is another thing........ :P

Comment 29 Pierre-YvesChibon 2012-02-22 08:23:20 UTC
(In reply to comment #27)
> Manually installing xfce4-notifyd is a workaround, not a resolution. The guake
> package should be updated so that xfce4-notifyd is a required dependency 

Guake is aimed at GNOME, as such I don't think it will ever require xfce4-notifyd.

> or it needs to fixed so that it doesn't crash if xfce4-notifyd isn't installed.

This is more likely to happen.

Comment 30 Enrique 2012-02-25 00:06:08 UTC
Created attachment 565696 [details]
patch to avoid using the notification system if it is not working


 Hi there,
 I created a possible patch that will detect whether the notification system is working and use it only in this case. The patch is really simple, but maybe it should be reviewed. Maybe it could be sent upstream as well?

 I attach the patch as guake.patch to the ticket.

 Regards,
 Enrique

Comment 31 Fedora Update System 2012-02-27 08:48:09 UTC
guake-0.4.2-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/guake-0.4.2-7.fc15

Comment 32 Fedora Update System 2012-02-27 08:48:21 UTC
guake-0.4.2-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/guake-0.4.2-7.fc16

Comment 33 Fedora Update System 2012-02-27 08:48:31 UTC
guake-0.4.2-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/guake-0.4.2-7.fc17

Comment 34 Fedora Update System 2012-02-27 08:48:41 UTC
guake-0.4.2-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/guake-0.4.2-6.el6

Comment 35 Pierre-YvesChibon 2012-02-27 08:56:50 UTC
Thanks for the patch.

As you can see I have included it and made a release with it. Please test it and let me know if it fixes the problem.

Comment 36 Fedora Update System 2012-02-27 22:30:07 UTC
Package guake-0.4.2-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing guake-0.4.2-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2522/guake-0.4.2-7.fc17
then log in and leave karma (feedback).

Comment 37 jckenny02 2012-03-06 01:20:02 UTC
Installed guake-0.4.2-7.fc16.x86_64 from updates-testing and it no longer crashes if xfce4-notifyd is not installed. Thanks.

Comment 38 Fedora Update System 2012-03-10 21:54:48 UTC
guake-0.4.2-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 39 Fedora Update System 2012-03-10 21:56:05 UTC
guake-0.4.2-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 40 Fedora Update System 2012-03-11 17:03:29 UTC
guake-0.4.2-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 41 Fedora Update System 2012-04-23 22:53:01 UTC
guake-0.4.2-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.