Bug 710875 - can not start puppetmaster service
Summary: can not start puppetmaster service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 15
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-05 12:32 UTC by Cristian Ciupitu
Modified: 2011-06-24 03:54 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-3.9.16-30.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-24 03:54:59 UTC


Attachments (Terms of Use)

Description Cristian Ciupitu 2011-06-05 12:32:38 UTC
Description of problem:
I can not start the  puppetmaster service because of SELinux denials.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.9.16-26.fc15.noarch

How reproducible:
Every time

Steps to Reproduce:
1. service puppetmaster start (no special configuration needed)

Actual results:
time->Sun Jun  5 14:59:14 2011
type=SYSCALL msg=audit(1307275154.587:75): arch=c000003e syscall=83 success=no exit=-13 a0=37d4440 a1=1ed a2=0 a3=7fff68357990 items=0 ppid=3749 pid=3750 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="puppetmasterd" exe="/usr/bin/ruby" subj=system_u:system_r:puppetmaster_t:s0 key=(null)
type=AVC msg=audit(1307275154.587:75): avc:  denied  { create } for  pid=3750 comm="puppetmasterd" name="puppet" scontext=system_u:system_r:puppetmaster_t:s0 tcontext=system_u:object_r:puppet_var_run_t:s0 tclass=dir

Expected results:
No SELinux denials

Additional info:
I'm using:
puppet-server-0.25.5-2.fc15.noarch
systemd-26-2.fc15.x86_64.rpm
systemd-sysv-26-2.fc15.x86_64.rpm
systemd-units-26-2.fc15.x86_64.rpm

Comment 1 Miroslav Grepl 2011-06-06 08:42:00 UTC
Fixed in selinux-policy-3.9.16-28.fc15

Comment 2 Fedora Update System 2011-06-10 10:50:41 UTC
selinux-policy-3.9.16-29.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-29.fc15

Comment 3 Fedora Update System 2011-06-11 04:29:54 UTC
Package selinux-policy-3.9.16-29.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.9.16-29.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-29.fc15
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-06-21 17:32:03 UTC
Package selinux-policy-3.9.16-30.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.9.16-30.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-30.fc15
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-06-24 03:53:28 UTC
selinux-policy-3.9.16-30.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.