Bug 710882 - parted in rawhide fails with: parted: arch/linux.c:2800: linux_disk_commit: Assertion `_have_blkpg ()' failed.
parted in rawhide fails with: parted: arch/linux.c:2800: linux_disk_commit: A...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-05 09:44 EDT by Richard W.M. Jones
Modified: 2011-06-29 10:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-29 10:55:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2011-06-05 09:44:46 EDT
Description of problem:

When running parted in Rawhide from inside a VM, I see this
assertion.

Version-Release number of selected component (if applicable):

parted-2.4-1.fc16.x86_64

How reproducible:

100%

Steps to Reproduce:
1. parted -s -- /dev/vda mklabel msdos
  
Actual results:

parted: arch/linux.c:2800: linux_disk_commit: Assertion `_have_blkpg ()' failed.

Expected results:

Creates label.

Additional info:

It seems to be related to this patch:
http://lists.gnu.org/archive/html/bug-parted/2010-11/msg00019.html

My email machine is switched off at the moment, but when I get
it back I'll send an email to the parted mailing list about it.

Build log that failed:

http://koji.fedoraproject.org/koji/getfile?taskID=3111513&name=build.log
Comment 1 Richard W.M. Jones 2011-06-05 10:02:41 EDT
Just had a look at the code in _have_blkpg, and I wonder
if this has something to do with the Linux kernel version
being 3.0?
Comment 2 Richard W.M. Jones 2011-06-05 10:03:32 EDT
http://koji.fedoraproject.org/koji/getfile?taskID=3111513&name=root.log
in case you want to see the version number of Linux kernel
and other packages installed while parted was running.
Comment 3 Richard W.M. Jones 2011-06-05 10:10:39 EDT
(In reply to comment #1)
> Just had a look at the code in _have_blkpg, and I wonder
> if this has something to do with the Linux kernel version
> being 3.0?

Looks like parted is expecting the utsname release
string to contain 3 dotted numbers.  But in the new
kernel that string is "3.0".
Comment 4 Jim Meyering 2011-06-05 14:24:24 EDT
Thanks for the report.
I've posted a patch:

http://thread.gmane.org/gmane.comp.gnu.parted.devel/3529/focus=3530

The next kernel RPM should use 3.0.x, so very few users will encounter this problem with parted.
Comment 5 Richard W.M. Jones 2011-06-05 15:14:03 EDT
Since I don't have a Rawhide machine to test this on and
the patch *looks* good to me, I pushed it to Rawhide.   I will
try and build libguestfs against it, to see if it fixes the
problem.
Comment 6 Richard W.M. Jones 2011-06-07 13:17:12 EDT
I tested Jim's original patch and it fixed the problem.

Jim has now pushed a modified version of the patch
upstream.  Therefore I am closing this bug.
Comment 7 Richard W.M. Jones 2011-06-29 09:23:24 EDT
This bug has reappeared in parted-3.0-1.fc16.
Comment 8 Richard W.M. Jones 2011-06-29 09:27:23 EDT
Here is the error:

parted -s -- /dev/vda mklabel msdos
parted: arch/linux.c:2805: linux_disk_commit: Assertion `_have_blkpg ()' failed.
Comment 9 Richard W.M. Jones 2011-06-29 10:55:10 EDT
I pushed a fix in parted-3.0-2.fc16, and am rebuilding
libguestfs against this.  parted binary appears to run
without error now.

Note You need to log in before you can comment on or make changes to this bug.