Bug 710918 - plasma-desktop eats 100% CPU
Summary: plasma-desktop eats 100% CPU
Keywords:
Status: CLOSED DUPLICATE of bug 697350
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-05 19:36 UTC by MartinG
Modified: 2011-06-29 16:33 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-29 16:33:05 UTC


Attachments (Terms of Use)

Description MartinG 2011-06-05 19:36:34 UTC
User-Agent:       Opera/9.80 (X11; Linux x86_64; U; en) Presto/2.8.131 Version/11.11

I'm running a fully updated Fedora 15, and KDE. I use KWin without desktop effects (*).

When the system has been idling for a while, suddenly, plasma-desktop eats about 100% cpu. Sometimes those 100% are shared with ksysguardd.

I have all debuginfo packages installed, and have tried to attach to the plasma-desktop process with "gdb attach <pid>". When I do that, the cpu load drops, but it has resulted in a lock up of the whole system, requiring a hard restart.


(*) Desktop effects are not used because of https://bugs.freedesktop.org/show_bug.cgi?id=37896

Reproducible: Always

Steps to Reproduce:
1. Start system, use various plasmoid and programs
2. After a while, notice that the laptop gets very hot, and see in "top" that plasma-desktop eats cpu.




kernel-2.6.38.6-27.fc15.x86_64
ksysguardd-4.6.3-5.fc15.x86_64
kdebase-workspace-4.6.3-5.fc15.x86_64

Comment 1 MartinG 2011-06-05 19:39:37 UTC
Relevant output of "gdb attach <pid of plasma-destkop>":
Loaded symbols for /usr/lib64/kde4/plasma_engine_time.so
Reading symbols from /usr/lib64/kde4/akonadi_serializer_kcalcore.so...Reading symbols from /usr/lib/debug/usr/lib64/kde4/akonadi_serializer_kcalcore.so.debug...done.
done.
Loaded symbols for /usr/lib64/kde4/akonadi_serializer_kcalcore.so
0x00000031f36d73e3 in __poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
87        int result = INLINE_SYSCALL (poll, 3, CHECK_N (fds, nfds), nfds, timeout);
(gdb) bt
#0  0x00000031f36d73e3 in __poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000031f32430a4 in g_main_context_poll (n_fds=14, fds=0x2b8f350, priority=<optimized out>, timeout=963, context=0x19440c0) at gmain.c:3404
#2  g_main_context_iterate (context=0x19440c0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3086
#3  0x00000031f32435dc in g_main_context_iteration (context=0x19440c0, may_block=1) at gmain.c:3154
#4  0x00000031fc784d1f in QEventDispatcherGlib::processEvents (this=0x18d17e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#5  0x0000003200459f2e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#6  0x00000031fc7596d2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00000031fc7598cf in QEventLoop::exec (this=0x7fffbe5b0d30, flags=...) at kernel/qeventloop.cpp:201
#8  0x00000031fc75da17 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#9  0x0000003e3783f1e3 in kdemain (argc=1, argv=0x7fffbe5b1118) at /usr/src/debug/kdebase-workspace-4.6.3/plasma/desktop/shell/main.cpp:120
#10 0x00000031f362143d in __libc_start_main (main=0x400890 <main(int, char**)>, argc=1, ubp_av=0x7fffbe5b1118, init=<optimized out>, fini=<optimized out>, 
    rtld_fini=<optimized out>, stack_end=0x7fffbe5b1108) at libc-start.c:226
#11 0x00000000004008c1 in _start ()
(gdb) 


Same for "gdb attach <pid of ksysguardd>":
Loaded symbols for /lib64/ld-linux-x86-64.so.2
0x00000031f36d91d3 in __select_nocancel () at ../sysdeps/unix/syscall-template.S:82
82      T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
(gdb) bt
#0  0x00000031f36d91d3 in __select_nocancel () at ../sysdeps/unix/syscall-template.S:82
#1  0x0000000000406e67 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdebase-workspace-4.6.3/ksysguard/ksysguardd/ksysguardd.c:591
(gdb)

Comment 2 Phil Smith 2011-06-06 11:03:53 UTC
Same problem.  F15 fully updated.  Nvidia driver instead of nouveau (nouveau crashed every hour or so).  Handful of standard widgets and no desktop effects.
plasma-desktop at 100%, ksysguardd occasionally at 30%.

kernel-2.6.38.6-27.fc15.x86_64
ksysguardd-4.6.3-5.fc15.x86_64
kdebase-workspace-4.6.3-5.fc15.x86_64

Comment 3 Stefan Becker 2011-06-16 18:34:09 UTC
I've noticed the same problem on two Dell laptops with Nvidia chipsets:

a) the first was a company loaner, an old Latitude E54xx(?) with NV9x. I made a fresh F15 x86_64 install on that one and used the nouveau driver. If the laptop was "idle" over night then plasma-desktop would be busy looping the next morning.

b) now I got my own company laptop, a spanking new Dell Latitude E6420 with Quadro NVS 4200M. I did a brain transplant from the old laptop to the new one by dump & restoring /, /boot and /home. Unfortunately nouveau doesn't support this chipset yet, so I had to move to Nvidia driver from rpmfusion-nonfree, which is currently at 270.x.x.x. On this one I just noticed it the first time a few minutes after resuming from suspend.

On both kwin Desktop effects using OpenGL is actived.
AFAIR in all cases I had the power supply plugged in (maybe this is relevant).

Everytime I notice problem, I kill the plasma-desktop with SIGHUP and restart it from krunner.

Package information from the E6420:

kernel-2.6.38.7-30.fc15.x86_64
kdebase-workspace-4.6.3-5.fc15.x86_64
xorg-x11-drv-nvidia-270.41.06-1.fc15.x86_64

Comment 4 MartinG 2011-06-16 20:40:21 UTC
Some more bits from me: 
It happens regularly, and if I "killall plasma-desktop" and start it from a terminal, this is the printout:

localhost:~:$ plasma-desktop&
[1] 4821
localhost:~:$ QDBusObjectPath: invalid path ""
plasma-desktop(4822)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
plasma-desktop(4822)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 

[above message repeated about 15 times]

Object::connect: No such signal KWindowSystem::windowChanged(WId,unsigned long*)
plasma-desktop(4822)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
plasma-desktop(4822)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(127, 0) 
plasma-desktop(4822)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(127, 0) 
QGridLayoutEngine::addItem: Cell (1, 1) already taken
plasma-desktop(4822)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(127, 0) 
plasma-desktop(4822)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
Object::connect: No such signal QDBusAbstractInterface::Changed()
plasma-desktop(4822)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
plasma-desktop(4822)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
link XMLID_34_ hasn't been detected!
link XMLID_34_ hasn't been detected!
link XMLID_36_ hasn't been detected!
plasma-desktop(4822)/kdecore (services) KServicePrivate::init: The desktop entry file  "/usr/share/kde4/services/sysinfo.protocol"  has Type= "Application"  but no Exec line 

Object::connect: No such slot AbstractItemView::iconSettingsChanged()
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
plasma-desktop(4822)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
plasma-desktop(4822)/kio (KDirWatch) KDirWatchPrivate::removeEntry: doesn't know "" 
plasma-desktop(4822)/libkdepim Akonadi::PluginLoader::scan: missing or empty X-KDE-ClassName value in " "/usr/share/kde4/apps/akonadi/plugins/serializer/akonadi_serializer_contactgroup.desktop" " 

plasma-desktop(4822)/libkdepim Akonadi::PluginLoader::scan: missing or empty X-KDE-ClassName value in " "/usr/share/kde4/apps/akonadi/plugins/serializer/akonadi_serializer_kcalcore.desktop" " 

plasma-desktop(4822)/libkdepim Akonadi::PluginLoader::scan: missing or empty X-KDE-ClassName value in " "/usr/share/kde4/apps/akonadi/plugins/serializer/akonadi_serializer_kcal.desktop" " 

plasma-desktop(4822)/libkdepim Akonadi::PluginLoader::scan: missing or empty X-KDE-ClassName value in " "/usr/share/kde4/apps/akonadi/plugins/serializer/akonadi_serializer_addressee.desktop" " 

plasma-desktop(4822)/libkdepim Akonadi::PluginLoader::scan: missing or empty X-KDE-ClassName value in " "/usr/share/kde4/apps/akonadi/plugins/serializer/akonadi_serializer_bookmark.desktop" " 

plasma-desktop(4822)/libkdepim Akonadi::PluginLoader::scan: missing or empty X-KDE-ClassName value in " "/usr/share/kde4/apps/akonadi/plugins/serializer/akonadi_serializer_microblog.desktop" " 

plasma-desktop(4822)/libkdepim Akonadi::PluginLoader::scan: missing or empty X-KDE-ClassName value in " "/usr/share/kde4/apps/akonadi/plugins/serializer/akonadi_serializer_mail.desktop" " 


[1]+  Done                    plasma-desktop
localhost:~:$ plasma-desktop(4822)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
plasma-desktop(4822)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
plasma-desktop(4822)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 



The last line is also what I see after plasma-desktop and ksysguardd is hammering one CPU (the line is repeated several times).

(Thinkpad T400, Intel graphics, no compiz/desktop effects active)

Comment 5 James Hogan 2011-06-22 21:25:28 UTC
same here, nvidia chipset, using nouveau without desktop effects (Dell M1210)

Comment 6 gene c 2011-06-27 16:09:00 UTC
I have similar problem - Lenovo W520 sandy bridge with i915 graphics - no desktop effects.

Comment 7 Phil Smith 2011-06-29 00:12:15 UTC
I removed widgets until the problem went away after removing CPU monitor.

I started CPU monitor again and the problem started again.

Takes about 20 hr to reach 100% CPU.

See
  https://bugs.kde.org/show_bug.cgi?id=273214
others are seeing the same problem with CPU monitor running (though "suspect all widget use the ksysguard data engine are affected").

Try removing widgets, especially CPU monitor and see if the problem goes away.

Comment 8 gene c 2011-06-29 02:55:22 UTC
I did have weather applet on the desktop background - I removed it as I was aware of the CPU monitor issue ... so far the 100% CPU has not come back.

Comment 9 Rex Dieter 2011-06-29 16:33:05 UTC
marking as dup of previous bug related to cpu monitor plasma applet.

*** This bug has been marked as a duplicate of bug 697350 ***


Note You need to log in before you can comment on or make changes to this bug.