Bug 71095 - DHCP network installation improperly writes to /etc/hosts
Summary: DHCP network installation improperly writes to /etc/hosts
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: limbo
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-08 18:29 UTC by John Lathrop
Modified: 2007-04-18 16:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 19:36:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Lathrop 2002-08-08 18:29:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
NOTE: this is NOT a net-tools bug: it appears to be an installer bug.
PLATFORM: Limbo version 2.
When installing across a DDNS network using ISC's DHCP, and choosing DHCP and 
supplying the client's hostname, the installer improperly writes the client's 
hostname to the loopback interface in the /etc/hosts file.  This prevents the 
DDNS server from writing forward and reverse lookup files, although it will 
still hand out an IP address.  Fix: after installation, correct the /etc/hosts 
file, and either reboot or reactivate the network connection.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install choosing DHCP.
2.  Enter the computer's hostname during the installation.
3.
	

Actual Results:  The computer is given an IP address from the DHCP server, but 
the /etc/hosts file incorrectly includes the computer's hostname after 
127.0.0.1.

Expected Results:  The /etc/hosts file should read:

127.0.0.1  localhost.localdomain  localhost

Additional info:

Is the installer incorrectly writing to NEAT, the network configuration tool?   
I don't know.

My server: Red Hat 7.3 with ISC's dhcp-3.0.1rc9-1cra, and Red Hat's bind-9.2.0-
8.

The server is setup for DDNS, in a very standard ISC configuration.

NOTE: I've given this a HIGH severity rating, because of the massive irritation 
that would be involved when installing in a networked environment.

Comment 1 Michael Fulbright 2002-08-14 19:35:57 UTC
Jeremy this has been the behavious for ages, correct?

Comment 2 Jeremy Katz 2002-08-14 21:56:27 UTC
Yes.  If we don't do this, then things such as apache and sendmail will
regularly fail to startup, especially on laptops

Comment 3 David Juran 2003-12-04 20:50:09 UTC
Nevertheless this is very still very wrong. Furthermore a laptop which
is not connected to the network at startup will not receive any DHCP
response and will therefor go under the name of
'localhost.localdomain' which still is resolved to 127.0.0.1 so I
don't really see the problem.
Please reopen this bug and move it to Redhat Enterprise Linux 1


Note You need to log in before you can comment on or make changes to this bug.