Bug 711009 - /usr/sbin/named: symbol lookup error: /usr/sbin/named: undefined symbol: dns_cache_create3
/usr/sbin/named: symbol lookup error: /usr/sbin/named: undefined symbol: dns_...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
14
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 04:12 EDT by Michal Fojtik
Modified: 2013-04-30 19:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-10 06:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Fojtik 2011-06-06 04:12:09 EDT
Description of problem:

Bind is throwing this error after recent update.

Version-Release number of selected component (if applicable):

32:9.7.4-0.1.b1.fc14

How reproducible:

yum update bind
service bind restart
  
Actual results:

omicron mfojtik # /etc/init.d/named restart
Stopping named:                                            [  OK  ]
Starting named: /usr/sbin/named: symbol lookup error: /usr/sbin/named: undefined symbol: dns_cache_create3
                                                           [FAILED]

Expected results:

Graceful restart

Additional info:
Comment 1 Adam Tkac 2011-06-08 05:02:31 EDT
I'm not able to reproduce this issue. Are you sure you updated all bind-* packages together, especially do you have up2date bind-libs package?
Comment 2 Adam Tkac 2011-06-10 06:57:45 EDT
I'm sure this is not a bug, please update all bind-* packages to the latest release. Closing.
Comment 3 Brown, Zach 2011-07-20 18:57:02 EDT
Let me get this straight.

1) "yum update bind" succeeds and doesn't pull in any dependencies.

2) The update scripts kill named, named doesn't restart for lack its dependencies.

3) The suggested "please update all bind-* packages" doesn't work in the case where the named that is now dead was the system's resolver.

4) The admin gets to point resolv.conf at some public name server to get the machine working again by manually satisfying dependencies.

This isn't a bug?
Comment 4 james labocki 2011-07-21 16:14:22 EDT
I'm also seeing this same error. I ran `yum update bind* -y` and then ran `service named start`, but I'm still not able to successfully start a clean installation of bind. Any suggestions on how this has been resolved?
Comment 5 Michael Closson 2011-07-22 22:29:39 EDT
I hit this same problem.  I installed bind and bind-chroot and bind wouldn't start.

After updating bind-libs the problem went away.  Sounds like the rpm dependencies for bind need to be updated!

Before:

[root@zeta named]# service named start
Starting named: /usr/sbin/named: symbol lookup error: /usr/sbin/named: undefined symbol: dns_cache_create3


After:


[root@zeta named]# yum update bind-libs
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package bind-libs.x86_64 32:9.7.4-0.3.b1.fc14 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package         Arch         Version                    Repository     Size
=============================================================================
Updating:
 bind-libs       x86_64       32:9.7.4-0.3.b1.fc14       updates       843 k

Transaction Summary
=============================================================================
Upgrade       1 Package(s)

Total download size: 843 k
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 843 k
bind-libs-9.7.4-0.3.b1.fc14.x86_64.rpm                | 843 kB     00:01     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : 32:bind-libs-9.7.4-0.3.b1.fc14.x86_64                 1/2 
  Cleanup        : 32:bind-libs-9.7.3-1.fc14.x86_64                      2/2 

Updated:
  bind-libs.x86_64 32:9.7.4-0.3.b1.fc14                                      

Complete!


[root@zeta named]# service named start
Starting named:                                            [  OK  ]

Note You need to log in before you can comment on or make changes to this bug.