Bug 711151 - libvirt regression with creating encrypted volume
Summary: libvirt regression with creating encrypted volume
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.1
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: rc
: 6.1
Assignee: Eric Blake
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 676984
Blocks: 721335 726617
TreeView+ depends on / blocked
 
Reported: 2011-06-06 16:43 UTC by Eric Blake
Modified: 2013-01-09 23:55 UTC (History)
19 users (show)

Fixed In Version: libvirt-0.9.2-1.el6
Doc Type: Bug Fix
Doc Text:
Libvirt was previously using undocumented command line options, instead of the recommended ones during its use of the qemu-img utility. But the fix to have libvirt use the updated command line options introduced a regression that prevented the creation of an encrypted volume. With this update, the bug in qemu-img command line arguments has been fixed, and encrypted volumes can now be created as expected.
Clone Of: 676984
Environment:
Last Closed: 2011-12-06 11:12:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Comment 1 Eric Blake 2011-06-06 16:46:36 UTC
In POST with minimal patch, rather than full upstream backport:
http://post-office.corp.redhat.com/archives/rhvirt-patches/2011-June/msg00059.html

Comment 5 Daniel Veillard 2011-06-23 03:40:26 UTC
This should be fixed for RHEL-6.2 by the libvirt-0.9.2-1.el6 rebase,

Daniel

Comment 8 dyuan 2011-07-13 01:53:41 UTC
According to comment 6, move it to VERIFIED.

Comment 10 Tomas Capek 2011-08-18 13:58:30 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to a regression, libvirt used undocumented command line options, instead of the recommended ones. Consequently, the qemu-img utility used an invalid argument while creating an encrypted volume, and the process eventually failed. With this update, the bug in the backing format of the storage back end has been fixed, and encrypted volumes can now be created as expected.

Comment 11 Dave Allan 2011-08-22 17:05:19 UTC
Eric, is that a fair summary?

Comment 12 Eric Blake 2011-08-22 17:25:09 UTC
(In reply to comment #11)
> Eric, is that a fair summary?

I tweaked the wording.  The key point was that the earlier fix to avoid undocumented command lines introduced the regression the prevented use of encryption.

Comment 13 Eric Blake 2011-08-22 17:25:09 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Due to a regression, libvirt used undocumented command line options, instead of the recommended ones. Consequently, the qemu-img utility used an invalid argument while creating an encrypted volume, and the process eventually failed. With this update, the bug in the backing format of the storage back end has been fixed, and encrypted volumes can now be created as expected.+Libvirt was previously using undocumented command line options, instead of the recommended ones during its use of the qemu-img utility. But the fix to have libvirt use the updated command line options introduced a regression that prevented the creation of an encrypted volume. With this update, the bug in qemu-img command line arguments has been fixed, and encrypted volumes can now be created as expected.

Comment 14 errata-xmlrpc 2011-12-06 11:12:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.