Bug 711154 - error if ipv6 blacklisted and starting guest: cannot create bridge 'virbr1': Package not installed
error if ipv6 blacklisted and starting guest: cannot create bridge 'virbr1': ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
15
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 12:52 EDT by Cristian Ciupitu
Modified: 2012-07-04 15:08 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 20:24:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/rpmpkgs (log of installed packages) (44.81 KB, text/plain)
2011-06-06 12:52 EDT, Cristian Ciupitu
no flags Details

  None (edit)
Description Cristian Ciupitu 2011-06-06 12:52:42 EDT
Created attachment 503286 [details]
/var/log/rpmpkgs (log of installed packages)

Description of problem:
I tried to create a NAT virtual network in virtual-manager and got this error "Error creating virtual network: cannot create bridge 'virbr1': Package not installed". The details are:
        Traceback (most recent call last):
          File "/usr/share/virt-manager/virtManager/createnet.py", line 351, in finish
            self.conn.create_network(xml)
          File "/usr/share/virt-manager/virtManager/connection.py", line 743, in create_network
            net.create()
          File "/usr/lib64/python2.7/site-packages/libvirt.py", line 935, in create
            if ret == -1: raise libvirtError ('virNetworkCreate() failed', net=self)
        libvirtError: cannot create bridge 'virbr1': Package not installed

Version-Release number of selected component (if applicable):
virt-manager-0.8.7-4.fc15.noarch
libvirt-0.8.8-4.fc15.x86_64.rpm
libvirt-client-0.8.8-4.fc15.x86_64.rpm
libvirt-python-0.8.8-4.fc15.x86_64.rpm

How reproducible:
At least one time

Steps to Reproduce:
1. Start virt-manager.
2. Connect to localhost.
3. Add a NAT network without DHCP (I use my own ISC DHCP & BIND servers):
   - Summary: Nework name: network1
   - IPv4 network: Network: 192.168.123.0/24 ...
   - DHCP: Status: Disabled
   - Forwarding: Connectivity: NAT
  
Actual results:
"Error creating virtual network"

Expected results:
The network should be created.

Additional info:
I think that a dependency is missing.
Comment 1 Cristian Ciupitu 2011-06-06 18:37:19 EDT
It seems that this was caused by the blacklisting of the ipv6 kernel module. I used the method from http://fedorasolved.org/network-solutions/disable-ipv6 to disable IPv6, i.e. I created /etc/modprobe.d/blacklist-ipv6.conf with the following content:

  install ipv6 /bin/true
  blacklist ipv6
Comment 2 Cole Robinson 2011-07-11 13:01:44 EDT
This might be one of those 'don't do that' situations :) but I'm not sure if ipv6 should be required for virtual networking to work.

Either way, the error message is crappy, so we should fix that.
Comment 3 Fedora Admin XMLRPC Client 2011-09-22 13:52:24 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-09-22 13:55:45 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Harald Reindl 2011-11-27 13:22:31 EST
confirmed for F15 and affects any sort of "/usr/sbin/brctl addbr"
F14 has no problem with this

[root@thx1138:~]$ cat /etc/modprobe.d/disable-ipv6.conf 
blacklist ipv6
blacklist net-pf-10
install net-pf-10 /bin/true
install ipv6 /bin/true

[root@thx1138:~]$ ifconfig br0
br0       Link encap:Ethernet  Hardware Adresse 00:50:56:BD:00:03  
          inet Adresse:10.0.0.134  Bcast:10.0.0.255  Maske:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:340989 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:17813211 (16.9 MiB)  TX bytes:0 (0.0 b)
___________________________________________

on F15 "brctl" does not give the error if ipv6 is disabled as followed 

[root@srv-rhsoft:~]$ cat /etc/modprobe.d/disable-ipv6.conf 
options ipv6 disable=1
options net-pf-10 disable=1
Comment 6 Fedora Admin XMLRPC Client 2011-11-30 15:02:13 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-11-30 15:02:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2011-11-30 15:07:00 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2011-11-30 15:07:06 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Zdenek Kabelac 2012-05-18 04:23:46 EDT
libvirtd[497]: 2012-05-17 11:34:36.612+0000: 590: error : virCommandWait:2306 : vnitřní chyba Child process (/bin/sh -c IPT=/usr/sbin/ip6tables
libvirtd[497]: cmd='$IPT -n -L FORWARD'
libvirtd[497]: eval res=\$\("${cmd} 2>&1"\)
libvirtd[497]: if [ $? -ne 0 ]; then  echo "Failure to execute command '${cmd}' : '${res}'.";  exit 1;fi
libvirtd[497]: ) status unexpected: exit status 1
libvirtd[497]: 2012-05-17 11:34:36.614+0000: 590: error : ebiptablesDriverInit:4119 : Testing of ip6tables command failed: Failure to execute command '$IPT -n -L FORWARD' : 'ip6tables v1.4.12.2: can't initialize ip6tables table `filter': Table does not exist (do you need to insmod?)
libvirtd[497]: Perhaps ip6tables or your kernel needs to be upgraded.'.
libvirtd[497]: 2012-05-17 11:34:38.126+0000: 590: error : virDomainDefParseXML:8632 : nepodporovaná konfigurace: Only the first console can be a serial port


I've this in my /var/log/messages.
Perhaps it's the related issue?

My modprobe config has this 2 extra lines to disable IPv6 on my system:

# disable IPV6
alias net-pf-10 off
blacklist ipv6


libvirt-client-0.9.12-1.fc18.x86_64
libvirt-daemon-config-nwfilter-0.9.12-1.fc18.x86_64
libvirt-docs-0.9.12-1.fc18.x86_64
libvirt-daemon-0.9.12-1.fc18.x86_64


IMHO libvirt should be able to handle systems without IPv6.
Comment 11 Harald Reindl 2012-05-18 05:48:13 EDT
> My modprobe config has this 2 extra lines to disable IPv6 on my system:
>
> # disable IPV6
> alias net-pf-10 off
> blacklist ipv6

i guess the first one is your problem because "blacklist ipv6"
does no longer work, so you HAVE ipv6 (look at ifconfig, it is there) but 
disabled ip6tables

you have to use "ipv6.disable=1" as kernel-param to disable it really
Comment 12 Cole Robinson 2012-06-06 20:24:47 EDT
So sounds like this is just a side effect of not fully disabling ipv6, according to Harald in Comment #11. So NOTOURBUG at least :)

If anyone can still reproduce with fedora 17 though, please reopen.
Comment 13 Cristian Ciupitu 2012-07-04 15:08:49 EDT
libvirt-0.9.11.3-1.fc17.x86_64 works fine under Fedora 17 with IPv6 disabled in the way suggested by Harald Reindl.

Note You need to log in before you can comment on or make changes to this bug.