Bug 71117 - gnomemeeting hangs when started under KDE
gnomemeeting hangs when started under KDE
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnomemeeting (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-08 18:40 EDT by Hakan TERZIOGLU
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-10 16:30:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hakan TERZIOGLU 2002-08-08 18:40:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
Gnomemeeting works well under Gnome2, but when i tried to start it via konsole
manually under KdesktopEnvironment, it hangs and never starts.
I did strace and it said gnomemeeeting is in suspend. (it calls suspend)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.switchdesk KDE
2.startx
3.gnomemeeting
	

Actual Results:  nothing. It waits forever.

Expected Results:  run correctly under KDE

Additional info:
Comment 1 Alexander Larsson 2002-08-09 03:14:55 EDT
Looks like a deadlock while starting bonobo-activation.
Here is a backtrace:
(gdb) bt
#0  0x42027629 in sigsuspend () from /lib/i686/libc.so.6
#1  0x413d9f88 in __pthread_wait_for_restart_signal () from
/lib/i686/libpthread.so.0
#2  0x413dc2c0 in __pthread_alt_lock () from /lib/i686/libpthread.so.0
#3  0x413d8e57 in pthread_mutex_lock () from /lib/i686/libpthread.so.0
#4  0x40f308a2 in gdk_add_client_message_filter () from /usr/lib/libgdk-x11-2.0.so.0
#5  0x412246c8 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#6  0x41225039 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#7  0x4122593f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#8  0x410b9661 in bonobo_activation_server_by_forking () from
/usr/lib/libbonobo-activation.so.4
#9  0x410b9ee5 in local_activator () from /usr/lib/libbonobo-activation.so.4
#10 0x410b76a7 in bonobo_activation_activators_use () from
/usr/lib/libbonobo-activation.so.4
#11 0x410b788d in bonobo_activation_internal_service_get_extended () from
/usr/lib/libbonobo-activation.so.4
#12 0x410b799c in bonobo_activation_service_get () from
/usr/lib/libbonobo-activation.so.4
#13 0x410b9bb5 in bonobo_activation_activation_context_get () from
/usr/lib/libbonobo-activation.so.4
#14 0x410b9d45 in ac_check () from /usr/lib/libbonobo-activation.so.4
#15 0x410b7082 in bonobo_activation_base_service_check () from
/usr/lib/libbonobo-activation.so.4
#16 0x410b77e9 in bonobo_activation_internal_service_get_extended () from
/usr/lib/libbonobo-activation.so.4
#17 0x410b799c in bonobo_activation_service_get () from
/usr/lib/libbonobo-activation.so.4
#18 0x410b9c1e in bonobo_activation_object_directory_get () from
/usr/lib/libbonobo-activation.so.4
#19 0x410b807f in bonobo_activation_active_server_register () from
/usr/lib/libbonobo-activation.so.4
#20 0x080745c5 in gnomemeeting_invoke_factory(int, char**) ()
#21 0x080736d2 in gnomemeeting_init(_GmWindow*, _GmPrefWindow*, _GmLdapWindow*,
_GmRtpData*, _GmTextChat*, _GmCommandLineOptions*, int, char**, char**) ()
#22 0x080743bf in main ()
#23 0x42016664 in __libc_start_main () from /lib/i686/libc.so.6

It might be because in kde the bonobo-activation server is typically already
running, but in kde it has to be started.
Comment 2 Alexander Larsson 2002-08-10 07:25:19 EDT
Damien claims this is due to a bug in bonobo-activation that should be fixed in
versions later than 1.0.1. We better upgrade to 1.0.3.
Comment 3 Havoc Pennington 2002-08-10 10:41:18 EDT
we are on 1.0.3 now.
Comment 4 Alexander Larsson 2002-08-12 03:14:49 EDT
Yes, this seems to work with bonobo-activation 1.0.3 (and newest lic+orbit)

Note You need to log in before you can comment on or make changes to this bug.