Bug 711226 - Default permissions in spec file overriding per-directory permissions
Default permissions in spec file overriding per-directory permissions
Status: CLOSED DUPLICATE of bug 681540
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 17:33 EDT by David Shaw
Modified: 2011-06-07 02:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-07 02:50:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test spec file (262 bytes, application/octet-stream)
2011-06-06 17:33 EDT, David Shaw
no flags Details

  None (edit)
Description David Shaw 2011-06-06 17:33:58 EDT
Created attachment 503335 [details]
Test spec file

Description of problem:

When creating an rpm that has both a %defattr line and also a directory that has its mode set via %attr, the %defattr overrides the %attr instead of vice versa

Version-Release number of selected component (if applicable):

rpm-build-4.8.1-5.fc14.i686
rpm-4.8.1-5.fc14.i686

Steps to Reproduce:
1.  rpmbuild the attached testrpm.spec file.
2.  rpm -qplv /path/to/the/resulting/rpm/file
3.  Note the directory is 0755, but should be 0777
  
Actual results:

The directory is 0755

Expected results:

The directory should be 0777

Additional info:

FWIW, this worked in F11.
Comment 1 Panu Matilainen 2011-06-07 02:50:39 EDT

*** This bug has been marked as a duplicate of bug 681540 ***

Note You need to log in before you can comment on or make changes to this bug.