Bug 711253 - OpenSSH won't try all keys when using LXDE
OpenSSH won't try all keys when using LXDE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 21:07 EDT by eric@christensenplace.us
Modified: 2011-06-13 12:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-13 03:04:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
OpenSSH verbose log (9.81 KB, text/x-log)
2011-06-06 21:07 EDT, eric@christensenplace.us
no flags Details

  None (edit)
Description eric@christensenplace.us 2011-06-06 21:07:22 EDT
Created attachment 503354 [details]
OpenSSH verbose log

Description of problem: When using LXDE OpenSSH won't try all ssh keys to login to the other computer.  When using GNOME I don't see this behavior.


Version-Release number of selected component (if applicable): openssh.i686                         5.6p1-31.fc15.1 


How reproducible: Always


Steps to Reproduce:
1. Attempt to connect to server using crypto login.
2. 
3.
  
Actual results: OpenSSH attempts to use id_rsa and id_dsa but none of the other keys such as id_rsa.4.

Expected results: OpenSSH attempts to use any key available.


Additional info:
Comment 1 Jan F. Chadima 2011-06-09 07:13:42 EDT
Where you have the keys stored? Are you running the ssh-agent?
Comment 2 eric@christensenplace.us 2011-06-10 16:19:24 EDT
Keys are stored in ~/.ssh.  AFAIK, ssh-agent is working.  I can immediately go to GNOME and all works as expected.
Comment 3 Tomas Mraz 2011-06-13 03:04:10 EDT
The reason is that Gnome does not use ssh-agent but gnome-keyring in the ssh agent role. Gnome-keyring does this 'try all keys in .ssh' behavior.
Comment 4 eric@christensenplace.us 2011-06-13 11:32:16 EDT
So how do you fix this behavior?
Comment 5 Tomas Mraz 2011-06-13 12:43:01 EDT
There is nothing to fix. You can probably run gnome-keyring instead of ssh-agent in LXDE (I am not sure about that.) if you like this behavior so much.

Or you can add the keys by ssh-add <filename> with some script.

Note You need to log in before you can comment on or make changes to this bug.