Bug 711261 - Missing dependency ocaml-curl-devel -> libcurl-devel
Summary: Missing dependency ocaml-curl-devel -> libcurl-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml-curl
Version: 15
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Ekstrand
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-07 02:38 UTC by Michael Ekstrand
Modified: 2011-06-24 03:28 UTC (History)
3 users (show)

Fixed In Version: ocaml-curl-0.5.3-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-24 03:28:36 UTC


Attachments (Terms of Use)

Description Michael Ekstrand 2011-06-07 02:38:45 UTC
Description of problem:
ocaml-curl-devel should depend on libcurl-devel, but it does not.

Version-Release number of selected component (if applicable):
ocaml-curl-devel-0.5.3-2.fc15.i686

How reproducible:
Always.


Steps to Reproduce:
With ocaml-curl-devel installed but not libcurl-devel:
1. touch foo.ml
2. ocamlfind ocamlc -o foo -package curl -linkpkg foo.ml
  
Actual results:
/usr/bin/ld: cannot find -lcurl
collect2: ld returned 1 exit status
File "foo.ml", line 1, characters 0-1:
Error: Error while building custom runtime system

Expected results:
Generate a runnable program 'foo'.

Additional info:

Comment 1 Michael Ekstrand 2011-06-12 00:44:02 UTC
I have committed a change which adds curl-devel as a Requires: for both the ocaml-curl and ocaml-curl-devel packages.  Since ocaml-curl uses -custom rather than ocamlmklib for building the cma file, the curl-devel package is required to use it in the toplevel (and ocamlmktop is required for toplevel use).

Therefore, I propose this hard-wired dependency as a temporary solution until upstream starts using ocamlmklib (bug 712635).  If this is an acceptable solution, let me know & I can start a rawhide build and merge it to f15 as well.

Comment 2 Richard W.M. Jones 2011-06-12 18:27:02 UTC
Seems good to me ...

Comment 3 Fedora Update System 2011-06-13 17:08:07 UTC
ocaml-curl-0.5.3-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ocaml-curl-0.5.3-3.fc15

Comment 4 Fedora Update System 2011-06-15 05:42:48 UTC
Package ocaml-curl-0.5.3-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ocaml-curl-0.5.3-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ocaml-curl-0.5.3-3.fc15
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-06-24 03:28:31 UTC
ocaml-curl-0.5.3-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.