I upgraded to up2date-2.9.38-7.x.9.i386.rpm from rawhide (and all the required
So now up2date runs fine, but it still doesn't calculate the dependencies correctly.
I've got gstreamer 0.4.0 installed here, which has been built against ogg/vorbis
1.0rc3. This means that it requires libvorbisfile.so.0. Version 1.0 of ogg
vorbis seems to have a different so name.
To prevent this from becoming a problem, on the "Available Package Updates"
page, i first select all packages and then specifically deselect the libogg,
libvorbis and vorbis-tools packages. When i press Forward and it calculates the
dependencies it _still_ has taken these packages into account resulting in the
There was a package dependency problem. The message was:
Unresolvable chain of dependencies:
avifile 0.7.7.20020523-gst.1 requires libvorbisfile.so.0
gstreamer-vorbis-0.4.0-1 requires libvorbis >= 1.0beta4
gstreamer-vorbis 0.4.0-1 requires libvorbisenc.so.0
gstreamer-vorbis 0.4.0-1 requires libvorbisfile.so.0
Please modify your package selections and try again.
I did not use --force or --nodeps or any such thing when installed gstreamer.
Because of this, i have been unable to update anything here using up2date.
Not a bug as best I can tell. avifile and gstreamer are requiring
libvorbisenc.so.0 while limbo has /usr/lib/libvorbisenc.so.2.
In other words, thats not a solveable dependency, and any transaction
that needs to update libogg or libvorbis is going to be incomplete.
Best bet is to try and find or build newer versions of avifile/gstreamer
built against limbo.
The point is that i _specifically_ DEselected libogg, libvorbis and vorbis-tools
before clicking the Forward button. But up2date _still_ calculated the
dependencies for upgrading libogg, libvorbis and vorbis-tools from 1.0rc3 to 1.0.
The behavior i'm expecting is that when a package is deselected, up2date will
not try to update it anyway.
Hmm, could be. What other packages did you select?
I was assuming that some of the other packages had
deps on ogg/vorbis stuff and they were getting pulled
in as deps. That would show the behaviour you reported.
I selected everything (limbo betea 2 system, only updated up2date manually) and
then deselected libogg, libvorbis and vorbis-tools.
You could be right ofcourse that there's something else that requires ogg vorbis
1.0, but couldn't up2date tell me that then? I know i'm spoiled with red-carpet,
but it does an excellent job of telling the user what kind of dependency
conflicts there are.