Bug 711422 - Broken dependency on deprecated hal-info
Summary: Broken dependency on deprecated hal-info
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Linus Walleij
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-07 13:18 UTC by Nicola Soranzo
Modified: 2011-06-07 21:53 UTC (History)
1 user (show)

Fixed In Version: libmtp-1.0.6-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-07 21:53:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicola Soranzo 2011-06-07 13:18:01 UTC
Description of problem:
Since HAL has been deprecated upstream for 3 years, all major distributions are removing it. You can find more details on the accepted Fedora Feature page:

https://fedoraproject.org/wiki/Features/HalRemoval

The hal-info package has already been deprecated by its maintainer and blocked from composes for rawhide.
Therefore, the following broken dependency for your package should be removed:

libmtp-hal-1.0.6-2.fc16.i686 requires hal-info

Since no other package depends on libmtp-hal, I would suggest to completely remove the libmtp-hal subpackage for rawhide.

Version-Release number of selected component (if applicable):

libmtp-1.0.6-2.fc16

Comment 1 Linus Walleij 2011-06-07 21:35:03 UTC
OK I've kicked a build where libmtp-hal isn't in it...

Comment 2 Nicola Soranzo 2011-06-07 21:53:35 UTC
Thanks Linus, I'm closing the bug report then!


Note You need to log in before you can comment on or make changes to this bug.