Bug 711625 - Unable to create a cluster of KVM guests
Summary: Unable to create a cluster of KVM guests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
: 706553 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-08 00:17 UTC by Thomas Cameron
Modified: 2018-11-26 18:57 UTC (History)
7 users (show)

Fixed In Version: luci-0.23.0-15.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 09:45:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
luci.log (9.20 KB, application/octet-stream)
2011-06-08 00:17 UTC, Thomas Cameron
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 63168 None None None Never
Red Hat Product Errata RHBA-2011:1510 normal SHIPPED_LIVE luci bug fix update 2011-12-06 00:39:20 UTC

Description Thomas Cameron 2011-06-08 00:17:20 UTC
Created attachment 503593 [details]
luci.log

Description of problem:
KB article https://access.redhat.com/kb/docs/DOC-45145 describes defining a cluster service with a resource of a vm:

# Use a web browser to access the luci management application that administers this cluster
# Click "Clusters"
# Click the name of the cluster in question
# Click "Services"
# Click "Add"
# Enter the name of the virtual machine (as it appears in virsh list --all) into the "Service name" field
# Click "Add a resource"
# Select "Virtual Machine" from the drop down
# Enter /etc/libvirt/qemu into the "VM Configuration file path" field
# Click "Submit"

When I try, I get a 500 error and a traceback. I've attached luci.log

Version-Release number of selected component (if applicable):
luci-0.23.0-13.el6.x86_64

How reproducible:
# Click "Clusters"
# Click the name of the cluster in question
# Click "Services"
# Click "Add"
# Enter the name of the virtual machine (as it appears in virsh list --all) into the "Service name" field
# Click "Add a resource"
# Select "Virtual Machine" from the drop down
# Enter /etc/libvirt/qemu into the "VM Configuration file path" field
# Click "Submit"

Steps to Reproduce:
1.
2.
3.
  
Actual results:
500 error and traceback

Expected results:
Create a vm cluster

Additional info:

Comment 6 Ryan McCabe 2011-06-14 15:35:41 UTC
*** Bug 706553 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2011-12-06 09:45:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1510.html


Note You need to log in before you can comment on or make changes to this bug.