This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 71165 - logrotate of apache logs doesn't properly restart apache
logrotate of apache logs doesn't properly restart apache
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-09 10:27 EDT by James Pattie
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-11 16:43:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Pattie 2002-08-09 10:27:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.1a) Gecko/20020702

Description of problem:
When the logrotate of Apache happens, apache gets the HUP signal and proceeds to
shutdown, but never comes back up after the first logrotate.  From the command
line I can do the same command as the logrotate.d/apache script does and apache
will restart only on the first HUP sent.  If you try to restart it by a HUP
again it doesn't restart.  apache will start by doing 'service httpd start'
without blowing any errors and 'service httpd restart' works fine, it is just
the 'kill -HUP' version that is having problems.

All the updates are applied to the box.  The only non-standard thing is I am
running PHP 4.1.2 (rpms built on an updated RH7.2 box) so that Horde 2.1 can work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start apache
2.rotate logs (works fine first time)
3.rotate logs (day 2, won't restart)
	

Actual Results:  apache restarts the first day after it has been started, but
won't restart on the next day that logs are rotated.

Expected Results:  apache should have restarted.

Additional info:
Comment 1 Joe Orton 2002-09-11 16:03:13 EDT
Are any error log messages produced produced when you send the HUP manually?
(/var/log/httpd/error_log)
Comment 2 James Pattie 2002-09-11 16:43:07 EDT
I don't remember any errors being output, since I applied the recent php update
and everything is now working correctly.  You can close this bug if you like.  :)
Comment 3 Joe Orton 2002-09-11 16:54:29 EDT
Great. Thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.