Bug 711655 - AttributeError: 'NoneType' object has no attribute 'rfind'
AttributeError: 'NoneType' object has no attribute 'rfind'
Status: CLOSED DUPLICATE of bug 706542
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:11e0d1ca72b554604...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-08 00:44 EDT by Dan Barnes
Modified: 2011-06-15 03:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-08 09:47:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (260.09 KB, text/plain)
2011-06-08 00:48 EDT, Dan Barnes
no flags Details
Attached traceback automatically from anaconda. (278.51 KB, text/plain)
2011-06-10 01:43 EDT, Frantisek Hanzlik
no flags Details
Attached traceback automatically from anaconda. (262.28 KB, text/plain)
2011-06-15 03:26 EDT, Dan Barnes
no flags Details

  None (edit)
Description Dan Barnes 2011-06-08 00:44:06 EDT
The following was filed automatically by anaconda:
anaconda 15.31 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/posixpath.py", line 112, in basename
    i = p.rfind('/') + 1
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 422, in majorminor
    device = dm_node_from_name(os.path.basename(self.device))
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 271, in cacheMajorminor
    self.majorminor # this does the caching
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 700, in _preTeardown
    self.format.cacheMajorminor()
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 714, in teardown
    if not self._preTeardown(recursive=recursive):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1868, in teardownAll
    device.teardown(recursive=True)
  File "/usr/lib/python2.7/site-packages/pyanaconda/packages.py", line 103, in turnOnFilesystems
    anaconda.storage.devicetree.teardownAll()
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1257, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'rfind'
Comment 1 Dan Barnes 2011-06-08 00:48:34 EDT
Created attachment 503615 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2011-06-08 09:47:03 EDT

*** This bug has been marked as a duplicate of bug 706542 ***
Comment 3 Frantisek Hanzlik 2011-06-10 01:43:02 EDT
Created attachment 504015 [details]
Attached traceback automatically from anaconda.
Comment 4 Dan Barnes 2011-06-15 03:26:59 EDT
Created attachment 504816 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.